Bug 623090 - Fedora-14-Alpha-x86_64-Live.iso unable to boot
Summary: Fedora-14-Alpha-x86_64-Live.iso unable to boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-11 09:55 UTC by He Rui
Modified: 2013-01-10 06:08 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-11 20:09:56 UTC


Attachments (Terms of Use)

Description He Rui 2010-08-11 09:55:12 UTC
Description of problem:
Ran Fedora-14-Alpha-x86_64-Live.iso in kvm, but the screen turned totally black  where grub manual was supposed to be shown and no input worked after that. 

Version-Release number of selected component (if applicable):
Fedora-14-Alpha-x86_64-Live.iso from 
http://alt.fedoraproject.org/pub/alt/stage/14-Alpha.RC3.live/Fedora-14-Alpha-x86_64-Live/

How reproducible:
100%

Comment 1 Michal Schmidt 2010-08-11 10:32:28 UTC
Same here.
But it seems to be a host bug, because qemu-kvm crashes with:

KVM internal error. Suberror: 1
rax 000000001ffcf6d0 rbx 0000000000000000 rcx 0000000000000280 rdx 0000000000dfdfdf
rsi 0000000000000281 rdi 0000000000000008 rsp 000000001ffcf6cc rbp 000000001ffcfea8
r8  0000000000000000 r9  0000000000000000 r10 0000000000000000 r11 0000000000000000
r12 0000000000000000 r13 0000000000000000 r14 0000000000000000 r15 0000000000000000
rip 0000000020460098 rflags 00000282
cs 0020 (00000000/ffffffff p 1 dpl 0 db 1 s 1 type b l 0 g 1 avl 0)
ds 0028 (00000000/ffffffff p 1 dpl 0 db 1 s 1 type 3 l 0 g 1 avl 0)
es 0028 (00000000/ffffffff p 1 dpl 0 db 1 s 1 type 3 l 0 g 1 avl 0)
ss 0028 (00000000/ffffffff p 1 dpl 0 db 1 s 1 type 3 l 0 g 1 avl 0)
fs 0000 (00000000/0000ffff p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
gs 0000 (00000000/0000ffff p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
tr 0008 (00000580/00000067 p 1 dpl 0 db 0 s 0 type b l 0 g 0 avl 0)
ldt 0000 (00000000/0000ffff p 0 dpl 0 db 0 s 0 type 0 l 0 g 0 avl 0)
gdt ac20/2f
idt 100000/800
cr0 13 cr2 0 cr3 0 cr4 0 cr8 0 efer 0
emulation failure, check dmesg for details

My host system is a Fedora 13 + kernel 2.6.35-3.fc14.x86_64.
dmesg does not show any details about the crash.

Comment 2 Michal Schmidt 2010-08-11 10:44:33 UTC
With Fedora-14-Alpha-i686-Live.iso (14 Alpha RC3) it crashed in the same way.

An F-14 (Branched) guest which I got by upgrading from F-13 runs fine.

Comment 3 Michal Schmidt 2010-08-11 10:54:10 UTC
I have now put Fedora-14-Alpha-x86_64-Live.iso on a USB stick using liveusb-creator and tried to boot it on physical hardware. It ended with the same black screen!

So there really is something wrong with the image.
(That there's also a kvm bug is less important.)

My HW:
 CPU AMD Phenom(tm) II X6 1090T
 Asus M4A89TD PRO/USB3 (chipset AMD 890FX)

Comment 4 Michal Schmidt 2010-08-11 11:02:22 UTC
Fedora-14-Alpha-x86_64-netinst.iso boots fine (in KVM at least).

Comment 5 He Rui 2010-08-11 11:54:38 UTC
Same result on i386 platform.

Comment 6 Kamil Páral 2010-08-11 12:33:13 UTC
Same result for me. Live image, KVM, both architectures.

Comment 7 satellitgo 2010-08-11 13:28:22 UTC
Have to use upstart to boot:

At boot*hold <ESC> <TAB> linux0 init=/sbin/upstart  (add on command line of grub)
found this on:
Fedora-14-Alpha-RC3-i686-Live.iso
liveinst with net install to HD
And on NC Spin:
soas-i386-20100810.15.iso

Comment 8 Kevin Fenzi 2010-08-11 14:45:59 UTC
So, all of you are seeing a black screen? 

If you hold down shift when booting, then do 'linux0' at the boot: prompt does it come up?

Comment 9 Michal Schmidt 2010-08-11 15:13:06 UTC
(In reply to comment #8)
> If you hold down shift when booting, then do 'linux0' at the boot: prompt does
> it come up?    

This workaround works for me.

Comment 10 Kevin Fenzi 2010-08-11 15:44:19 UTC
ok, so this is likely bug https://bugzilla.redhat.com/show_bug.cgi?id=617115

A new livecd-tools was made for rawhide/f14 and is in updates-testing: 
https://admin.fedoraproject.org/updates/livecd-tools-033-3.fc14

The compose host for these spins was f13. ;( 
Dennis is updating the host now and will do another round of spins with the fixed livecd-tools.

Comment 11 satellitgo 2010-08-11 16:44:28 UTC

    f14 Alpha RC3 i686 Live CD (08/11/2010)
    USB external Hard Disk Install

    burn CD
    boot CD
    esc on boot edit boot line add "linux0" 
    liveinst install to HD: replace existing
    boot HD with esc on boot edit boot line add "linux0" 
    finish firstboot
    yum install nano
    # nano
    edit /boot/grub/menu.lst
    add "linux0" to boot line.
    save
    reboot
    Boots correctly from HD install with no intervention. logs in correctly
    f14 (Branched)

Comment 12 Adam Williamson 2010-08-11 20:04:42 UTC
new composes which have this issue fixed are now available at http://alt.fedoraproject.org/pub/alt/stage/14-Alpha.RC3.1.live/ . We can close this bug. I'll send a new announcement email.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Adam Williamson 2010-08-11 20:09:56 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Phil V 2010-10-11 20:59:40 UTC
Has this bug supposedly been fixed in the release of Fedora-14-Beta-x86_64-Live?

I've seen similar symptoms in Fedora-14-Beta-x86_64-Live.

Comment 15 Adam Williamson 2010-10-12 03:43:52 UTC
yes. whatever you're seeing is almost certainly not the same bug. please open a new bug and provide more details. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.