Bug 623106 - remove Provides: qt-devel from qt3-devel
remove Provides: qt-devel from qt3-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt3 (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
: 631652 (view as bug list)
Depends On:
Blocks: 631065
  Show dependency treegraph
 
Reported: 2010-08-11 07:11 EDT by Kalev Lember
Modified: 2010-09-15 23:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: qt3-3.3.8b-30.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 23:50:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2010-08-11 07:11:45 EDT
As discussed in https://bugzilla.rpmfusion.org/show_bug.cgi?id=1355#c45 qt3-devel having Provides: qt-devel is confusing and might result in an unwanted package (qt3-devel instead of qt-devel) getting installed.

I think it'd be much cleaner if qt3-devel didn't Provide something that's the name of another package:
$ repoquery --whatprovides qt-devel
qt-devel-1:4.6.3-8.fc13.i686
qt-devel-1:4.6.3-8.fc13.x86_64
qt-devel-1:4.6.2-16.fc13.i686
qt3-devel-0:3.3.8b-29.fc13.x86_64
qt3-devel-0:3.3.8b-29.fc13.i686
qt-devel-1:4.6.2-16.fc13.x86_64
qt-devel-1:4.6.3-8.fc13.i686
qt-devel-1:4.6.3-8.fc13.x86_64
Comment 1 Ngo Than 2010-08-11 08:00:07 EDT
it's fixed in 3.3.8b-30
Comment 2 Terje Røsten 2010-09-07 13:44:06 EDT
Hi, I need this in F14 as well, see https://bugzilla.redhat.com/show_bug.cgi?id=631065
Comment 3 Fedora Update System 2010-09-07 14:37:36 EDT
qt3-3.3.8b-30.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt3-3.3.8b-30.fc14
Comment 4 Kevin Kofler 2010-09-07 15:43:23 EDT
Well, the thing is, you should not NEED this change for your package to build. Just fix your package to BuildRequire qt4-devel, which is what we recommend anyway.
Comment 5 Fedora Update System 2010-09-07 23:19:33 EDT
qt3-3.3.8b-30.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt3'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt3-3.3.8b-30.fc14
Comment 6 Terje Røsten 2010-09-08 02:28:29 EDT
> Well, the thing is, you should not NEED this change for your package to build.
> Just fix your package to BuildRequire qt4-devel, which is what we recommend
> anyway.

Ok, I got a hint from Rex about that, package is fixed.
Comment 7 Kevin Kofler 2010-09-08 07:09:23 EDT
*** Bug 631652 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2010-09-15 23:50:29 EDT
qt3-3.3.8b-30.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.