Bug 62314 - (NET EPIC100) epic100 network driver fails
(NET EPIC100) epic100 network driver fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 10:40 EST by Ted Wright
Modified: 2013-07-02 22:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'lspci -vvv' (6.62 KB, patch)
2002-10-28 07:57 EST, Ted Wright
no flags Details | Diff
output of 'ethtool eth0' before forcing a link (411 bytes, patch)
2002-10-28 07:58 EST, Ted Wright
no flags Details | Diff
output of 'ethtool eth0' after forcing a link (413 bytes, patch)
2002-10-28 07:59 EST, Ted Wright
no flags Details | Diff

  None (edit)
Description Ted Wright 2002-03-29 10:40:42 EST
Description of Problem:
Original skipjack-beta1 kernel worked fine. After updating to the 2.4.18-0.8
kernel, my Ositech Jack of Spades Cardbus ethernet card (epic100 module) did not 
autonegotiate a link. Using mii-tool to force 100 Mbit full duplex, a link was
established, but stressing the network connection would eventually cause it to 
freeze.

Version-Release number of selected component (if applicable):
kernel-2.4.18-0.8

How Reproducible:
Network connection froze the 4 times I tried it, after transferring data 
for 30-90 seconds. 

Steps to Reproduce:
1. No link at boot, until I do 'mii-tool -F 100baseTx-FD'  
2. start a large network transfer (I used scp to copy Redhat/RPMS/*)
3. files get copied for about 30 seconds, then the network stops
Comment 1 Arjan van de Ven 2002-04-05 09:29:38 EST
Can you try 2.4.18-0.13 or later ? should have an older epic100 driver
Comment 2 Ted Wright 2002-04-11 13:20:59 EDT
I did a complete re-install with Skipjack beta2 (kernel 2.4.18-0.13), and the
network hanging problem is no longer happening. However, I still have to use
mii-tool to force 100baseTx-FD mode in order to get a network link. All previous
Red Hat 7.x releases have automatically detected and configured the card.
Comment 3 Ted Wright 2002-04-12 09:24:12 EDT
After updating to kernel package 2.4.18-0.20, the network freeze problem has
returned. I still had to force the link mode as well.
Comment 4 Ted Wright 2002-04-17 08:08:49 EDT
The problem is still present with the 2.4.18-0.22 kernel update (and all other
updates available through up2date) applied.
Here's another detail about the network freeze: it does not just freeze
networking on the laptop on which I installed Skipjack, but also takes out the
Netgear FS508 fast ethernet switch that the laptop is plugged into. All
computers plugged into the switch lose networking until the switch is rebooted. 
Maybe this problem only happens with this particular combination of cardbus
interface and switch, but it did not happen with this same hardware in any
previous version of Red Hat Linux at least as far back as version 6.2.
Comment 5 Jeff Garzik 2002-10-25 15:31:07 EDT
Picking this issue back up, can you reproduce this problem with 8.0 kernel,
or the stock kernel.org epic100 driver?

If so, can you provide "lspci -vvv" output, run as root,
and output of "ethtool eth0"?
Comment 6 Ted Wright 2002-10-28 07:57:44 EST
Created attachment 82366 [details]
output of 'lspci -vvv'
Comment 7 Ted Wright 2002-10-28 07:58:54 EST
Created attachment 82367 [details]
output of 'ethtool eth0' before forcing a link
Comment 8 Ted Wright 2002-10-28 07:59:39 EST
Created attachment 82368 [details]
output of 'ethtool eth0' after forcing a link
Comment 9 Ted Wright 2002-10-28 08:00:23 EST
I switched to 3Com 3ccFE575CT cards on these machines (which work fine), but for
this test I reinserted the Ositech JOS card and booted Red Hat 8.0 with
kernel-2.4.18-17.8.0. I made no manual configuration changes after switching cards.

- There was no link detected at boot
- Running 'mii-tool -F 100baseTx-FD' forced a working link
- I copied a large (iso) file without any network lockup (this is new)
- Copy performance was bad: the copy took 6 times as long as it should, and
there were lots of 'collision' lights on the switch (this is also new) 

I've attached the output of "lspci -vvv" and "ethtool eth0" run before forcing
the link, and "ethtool eth0" after forcing the link (output of "lspci -vvv" did
not change after forcing a link).
Comment 10 Bugzilla owner 2004-09-30 11:39:28 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.