Bug 623169 - In dualhead setup, I could not move cursor from one screen to another near the bottom of screen
In dualhead setup, I could not move cursor from one screen to another near th...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: RHELNAK, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 10:09 EDT by Miroslav Suchý
Modified: 2012-11-23 05:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In some multi-monitor configurations (e.g. dual monitors with both rotated), the cursor confinement code produces incorrect results. For example, the cursor may be permitted to disappear offscreen when it should not, or be prevented from entering some areas where it should be allowed to go. Currently, the only work around to this issue is to disable monitor rotation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 12:47:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (132.46 KB, text/plain)
2010-08-11 10:10 EDT, Miroslav Suchý
no flags Details

  None (edit)
Description Miroslav Suchý 2010-08-11 10:09:28 EDT
Description of problem:
I have dual head (true dual head, no xinerama, but :0 and :1) and I can move cursor from one screen to second without problem. But near bottom of the screen is something like invisible wall and I could not drag mouse through this area.

The monitors have different resolution 1280x1024 and 1600x1200 rotated using xrandr to 1024x1280 resp. 1200x1600. But the barrier start at 1150 (on monitor with height 1280) resp. at 1180 (on monitor with height 1600).

Version-Release number of selected component (if applicable):
$ rpm -qa |grep xorg-
xorg-x11-drv-void-debuginfo-1.3.0-4.el6.x86_64
xorg-x11-fonts-misc-7.2-9.1.el6.noarch
xorg-x11-utils-debuginfo-7.4-8.el6.x86_64
xorg-x11-proto-devel-7.4-35.el6.noarch
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-drv-evdev-debuginfo-2.3.2-8.el6.x86_64
xorg-x11-xauth-1.0.2-7.1.el6.x86_64
xorg-x11-drv-ati-6.13.0-6.el6.x86_64
xorg-x11-server-common-1.7.7-23.el6.x86_64
xorg-x11-utils-7.4-8.el6.x86_64
xorg-x11-drv-vesa-2.3.0-1.el6.x86_64
xorg-x11-apps-7.4-10.el6.x86_64
xorg-x11-xinit-1.0.9-13.el6.x86_64
xorg-x11-server-Xorg-1.7.7-23.el6.x86_64
xorg-x11-apps-debuginfo-7.4-10.el6.x86_64
xorg-x11-xdm-1.1.6-14.1.el6.x86_64
xorg-x11-drv-vesa-debuginfo-2.3.0-1.el6.x86_64
xorg-x11-drv-ati-firmware-6.13.0-6.el6.noarch
xorg-x11-drv-ati-debuginfo-6.13.0-6.el6.x86_64
xorg-x11-server-utils-debuginfo-7.4-15.el6.x86_64
xorg-x11-drv-evdev-2.3.2-8.el6.x86_64
xorg-x11-font-utils-7.2-10.el6.x86_64
xorg-x11-xdm-debuginfo-1.1.6-14.1.el6.x86_64
xorg-x11-drv-void-1.3.0-4.el6.x86_64
xorg-x11-font-utils-debuginfo-7.2-10.el6.x86_64
xorg-x11-xkb-utils-7.4-6.el6.x86_64
xorg-x11-xinit-debuginfo-1.0.9-13.el6.x86_64
xorg-x11-xauth-debuginfo-1.0.2-7.1.el6.x86_64
xorg-x11-xkb-utils-debuginfo-7.4-6.el6.x86_64

I use ati driver

How reproducible:
always

Steps to Reproduce:
1. set up dual head on two monitors with different resolution
2. rotate both display
3. try to move cursor from smaller monitor to second one aprox. 1 cm from bottom
  
Actual results:
there is invisible wall

Expected results:
mouse cursor should go through this area

Additional info:
Comment 1 Miroslav Suchý 2010-08-11 10:10:16 EDT
Created attachment 438193 [details]
Xorg.0.log
Comment 3 RHEL Product and Program Management 2010-08-11 10:38:27 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Miroslav Suchý 2010-08-12 04:39:57 EDT
I tested packages from https://bugzilla.redhat.com/show_bug.cgi?id=623083#c6
and interesting thing happend.
I can move cursor from right (bigger) to left (smaller) screen as previously.
But if I try to move cursor from left to right is is not possible. On whole right edge of left screen is that invisible wall and only place where I can go from left to right is that small area of 1 cm at bottom, where previously was that invisible wall. I.e. that invisible wall negated on left window.
Comment 6 RHEL Product and Program Management 2010-08-18 17:30:34 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 9 Denise Dumas 2010-09-13 10:52:34 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In some multihead scenarios when both monitors are rotated, the cursor
confinement code produces incorrect results.  This may manifest as the cursor
being allowed to disappear offscreen when it should not, or as being prevented
from entering some areas where it should be allowed to go.  As a workaround,
disable rotation.
Comment 10 Ryan Lerch 2010-09-23 02:19:44 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,5 +1 @@
-In some multihead scenarios when both monitors are rotated, the cursor
+In some multi-monitor configurations (e.g. dual monitors with both rotated), the cursor confinement code produces incorrect results. For example, the cursor may be permitted to disappear offscreen when it should not, or be prevented from entering some areas where it should be allowed to go. Currently, the only work around to this issue is to disable monitor rotation.-confinement code produces incorrect results.  This may manifest as the cursor
-being allowed to disappear offscreen when it should not, or as being prevented
-from entering some areas where it should be allowed to go.  As a workaround,
-disable rotation.
Comment 12 RHEL Product and Program Management 2011-02-01 01:06:01 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 13 RHEL Product and Program Management 2011-02-01 13:33:07 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 14 RHEL Product and Program Management 2011-04-03 22:34:01 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 15 Adam Jackson 2011-08-17 12:47:55 EDT
Should be fixed in 6.2, please reopen if not.

Note You need to log in before you can comment on or make changes to this bug.