Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623209 - Ada program uses word size as 64 bit even when gnatmake is passed -m32 flag
Ada program uses word size as 64 bit even when gnatmake is passed -m32 flag
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks: 590060
  Show dependency treegraph
 
Reported: 2010-08-11 11:47 EDT by Alan Matsuoka
Modified: 2011-05-13 08:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 11:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test.tar.gz (1.33 KB, application/x-gzip)
2010-08-11 11:48 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2010-08-11 11:47:43 EDT
Arch: x86_64

Problem Description:

The ADA system files that are part of the gcc-gnat package on a 64 bit system hard code word size (the size of an address or a pointer) as 64 bits. It does this even if you pass gnatmake the “-m32” flag.

How Reproducible:

Always

Steps to Reproduce:

Make and run the test program attached

Actual Results:

Opening the file
Writing the full integer
ADA.IO_EXCEPTIONS.DEVICE_ERROR
s-fileio.adb:1083
ADA_WRITE_TEST.FILE_WRITE_ERROR
ada_write_test.adb:58

Expected Results:

Opening the file
Writing the full integer
Closing the file
GOODBYE!

Additional Information:

The issue is fixed upstream with a package restructure. The adainclude and adalib contents have been put in a separate libgnat-devel package so that one may install libgnat-devel.i386 as well as libgnat-devel.x86_64 to get the desired files.
Comment 1 Alan Matsuoka 2010-08-11 11:48:55 EDT
Created attachment 438219 [details]
test.tar.gz
Comment 2 Jakub Jelinek 2010-08-11 11:54:25 EDT
In RHEL5, gnat only supports the primary platform.  The amount of changes for multiarch ada support was huge and are really not backportable.

Note You need to log in before you can comment on or make changes to this bug.