Bug 623271 - anyremote may need to be rebuilt against Python 2.7 in F14 and rawhide
anyremote may need to be rebuilt against Python 2.7 in F14 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anyremote (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: anyremote
Fedora Extras Quality Assurance
: Reopened
Depends On: 623233
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-11 14:27 EDT by Dave Malcolm
Modified: 2010-08-23 21:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: anyremote-5.1.3-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 21:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-11 14:27:47 EDT
This is an automatically-filed bug.

anyremote-5.1.3-1.fc14 contains one or more .pyc files, but has not been rebuilt since Python 2.7 was built for Fedora, and thus the .pyc files presumably are for Python 2.6.  Python 2.7 changed the bytecode format, so usage of those files will typically fail (see e.g. bug 621726).

The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

I'm sorry that this component was not handled by the mass rebuild.  (This may be due to bug 623233)
Comment 1 anyremote 2010-08-11 14:31:41 EDT
anyRemote does not depends from python
Comment 2 anyremote 2010-08-11 14:32:10 EDT
.
Comment 3 Dave Malcolm 2010-08-11 14:41:45 EDT
Looks like anyremote-data has a python script, which has been byte-compiled for 2.6:

# rpm -q anyremote
anyremote-5.1.3-1.fc14.x86_64

# rpm -q anyremote-data
anyremote-data-5.1.3-1.fc14.x86_64

# rpm -ql anyremote-data | grep py
/usr/share/anyremote/cfg-data/Utils/all-in-1.py
/usr/share/anyremote/cfg-data/Utils/all-in-1.pyc
/usr/share/anyremote/cfg-data/Utils/all-in-1.pyo

# file /usr/share/anyremote/cfg-data/Utils/all-in-1.py?
/usr/share/anyremote/cfg-data/Utils/all-in-1.pyc: python 2.6 byte-compiled
/usr/share/anyremote/cfg-data/Utils/all-in-1.pyo: python 2.6 byte-compiled
Comment 4 anyremote 2010-08-11 14:51:08 EDT
i have:

rpm -ql anyremote-data | grep py
/usr/share/anyremote/cfg-data/Utils/all-in-1.py

rpm -q anyremote-data
anyremote-data-5.1.3-1.fc13.i686

How and where do You obtain Your anyremote-data-5.1.3-1.fc14.x86_64 ?

In any case 
/usr/share/anyremote/cfg-data/Utils/all-in-1.pyc
/usr/share/anyremote/cfg-data/Utils/all-in-1.pyo
should not be a part of package.
Comment 5 Dave Malcolm 2010-08-11 15:06:13 EDT
> How and where do You obtain Your anyremote-data-5.1.3-1.fc14.x86_64 ?
http://koji.fedoraproject.org/koji/buildinfo?buildID=183201

The pyc/pcyo files are visible here:
http://koji.fedoraproject.org/koji/rpminfo?fileStart=150&rpmID=2066032&fileOrder=name&buildrootOrder=-id&buildrootStart=0#filelist

> In any case 
> /usr/share/anyremote/cfg-data/Utils/all-in-1.pyc
> /usr/share/anyremote/cfg-data/Utils/all-in-1.pyo
> should not be a part of package.    

I think what's happened is that rpmbuild has started byte-compiling more files since F13.
Comment 6 Fedora Update System 2010-08-11 17:31:30 EDT
anyremote-5.1.3-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/anyremote-5.1.3-2.fc14
Comment 7 Fedora Update System 2010-08-12 15:55:57 EDT
anyremote-5.1.3-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anyremote'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/anyremote-5.1.3-2.fc14
Comment 8 Fedora Update System 2010-08-23 21:24:16 EDT
anyremote-5.1.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.