Bug 62329 - ide-cdrom and ide-scsi conflict?
ide-cdrom and ide-scsi conflict?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 13:40 EST by Stephen John Smoogen
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 01:01:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2002-03-29 13:40:54 EST
Description of Problem:

kudzu not fully setting up hardware with IDE CDRW on system?

I just got my new machine at LANL (A Dell Precision 530.. real nice), and
installed Beta 3 onto it. During the install it noticed that my machine has an
writable IDE cdrom in it and if I wanted the additional flag hdc=ide-scsi. I
agreed to that, and it seems to have made the link for /dev/cdrom to /dev/scd0

It however did not seem to add anything to /etc/modules.conf or to the
/etc/grub.conf file.

an lsmod shows...
sr_mod                 16056   0  (autoclean)
i810_audio             26912   0  (autoclean)
ac97_codec              9888   0  (autoclean) [i810_audio]
soundcore               5444   2  (autoclean) [i810_audio]
radeon                 96888   2 
agpgart                34848   3 
autofs                 13156   0  (autoclean) (unused)
3c59x                  28072   1 
ipchains               44012  28 
ide-scsi                8832   0 
ide-cd                 27712   0 
cdrom                  28288   0  [sr_mod ide-cd]
usb-uhci               26276   0  (unused)
usbcore                58496   1  [usb-uhci]
ext3                   70816   4 
jbd                    50112   4  [ext3]
raid1                  18756   4 
raid0                   3968   1 
aic7xxx               137760  10 
sd_mod                 11776  20 
scsi_mod              110612   4  [sr_mod ide-scsi aic7xxx sd_mod]


I can play cd's in the system, but when I run cdparanoia I get the following:

cdparanoia III release 9.8 (March 23, 2001)
(C) 2001 Monty and Xiphophorus

Report bugs to paranoia@xiph.org
http://www.xiph.org/paranoia/ Checking /dev/cdrom for cdrom...
        Testing /dev/cdrom for cooked ioctl() interface
                /dev/scd0 is not a cooked ioctl CDROM.
        Testing /dev/cdrom for SCSI interface
                No generic SCSI device found to match CDROM device /dev/scd0
Version-Release number of selected component (if applicable):


System info:

AIC7xxx SCSI controller

root:{proc}# cat scsi/scsi
Attached devices: 
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: FUJITSU  Model: MAN3184MP        Rev: 5507
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: FUJITSU  Model: MAN3184MP        Rev: 5507
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: LITE-ON  Model: LTR-24102M       Rev: 4DS3
  Type:   CD-ROM                           ANSI SCSI revision: 02

The cdrom is being seen:

Looking at /dev/hd[abcd] and /dev/scd0

smoogen:{smoogen}$ ls -l /dev/hd[abcd] /dev/scd0
brw-rw----    1 root     disk       3,   0 Feb 21 12:26 /dev/hda
brw-rw----    1 root     disk       3,  64 Feb 21 12:26 /dev/hdb
brw-rw----    1 root     disk      22,   0 Feb 21 12:26 /dev/hdc
brw-rw----    1 root     disk      22,  64 Feb 21 12:26 /dev/hdd
brw-------    1 smoogen  disk      11,   0 Feb 21 12:26 /dev/scd0

Is it something I am doing wrong?
Comment 1 Stephen John Smoogen 2002-03-29 14:10:47 EST
Ok it is definately a permission problem of some sort:

I can do this as root, but cannot as user smoogen. I have tried the following to
see if it would clear it up:

change /etc/modules.conf

options ide-cd ignore=hdc # tell the ide-cd module to ignore hdc
alias scd0 sr_mod # load sr_mod upon access of scd0
pre-install sg modprobe ide-scsi # before sg, load ide-scsi
pre-install sr_mod modprobe ide-scsi # before sr_mod, load ide-scsi

and

rmmod ide-cdrom

None of these changes affected the problem.

I have removed them, and am looking for something very obvious that I am missing.
Comment 2 Stephen John Smoogen 2002-03-29 14:44:31 EST
The fix is to make the scsi generic device associated with the cdrom also
readable by the user. I did this via a 

ln -s /dev/sg2 /dev/cdrom1

but I can understand if this would be a tricky kudzu issue.. as kudzu would need
to see if there are any ide-scsi devices and then work out which one was the
cdrom and what its generic device should be.
Comment 3 Stephen John Smoogen 2002-12-30 14:49:11 EST
At this point, I am going to say this is a feature enhancement request for kudzu
someday in the far future. The bug should probably be closed or changed by RH
engineers.
Comment 4 Bill Nottingham 2003-01-30 01:01:31 EST
Done in 0.99.91-1 as part of updfstab.

Note You need to log in before you can comment on or make changes to this bug.