Bug 6233 - smbmnt segfault
Summary: smbmnt segfault
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 10:41 UTC by michael_wardle
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-29 21:22:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description michael_wardle 1999-10-22 10:41:04 UTC
smbmount fails to resolve a host

command issued:
smbmount "//STANNS_SERVER/USERS" /mnt/server -U ... -W ...

on a local (C class?) network which has a SMB fileserver

tried as root and a non-privileged user

traced behaviour to smbmnt which seg faults on my system
when running the command, regardless of parameters

Comment 1 Bill Nottingham 1999-10-22 14:43:59 UTC
I can't reproduce this here.

Is stanns_server a DNS name, or only a WINS name?  Are you
using a WINS server?

Comment 2 michael_wardle 1999-10-23 03:51:59 UTC
I assume that it's only a WINS name, as our name server would be
172.22.6.1 (the IP for the SMB server is 172.22.6.51).

I don't administer the network, so I can't tell you too much more, but
I could connect perfectly normally to the server in Red Hat 6.0, so I
am guessing that this is a fault with the new smbmnt.

Perhaps it is just my smb.conf file, although I can't see how.

Comment 3 Bill Nottingham 1999-10-25 16:29:59 UTC
What's the full command line you are using? The flags
to smbmnt changed fairly significantly.

Comment 4 michael_wardle 1999-10-26 01:09:59 UTC
COMMAND:
smbclient -L STANNS_SERVER
OUTPUT:
Added interface ip=172.22.6.240 bcast=172.22.6.255 nmask=255.255.255.0
Connection to STANNS_SERVER failed

COMMAND:
smbmount "//STANNS_SERVER/USERS" /mnt/server -U mwardle -W STANNS
OUTPUT:
Added interface ip=172.22.6.240 bcast=172.22.6.255 nmask=255.255.255.0
smb_retry: no connection process
Could not resolve mount point /mnt/server

COMMAND:
smbmnt
OUTPUT:
Segmentation fault

Can send smb.conf file if it would be useful, although I think this is
used only if my box is an SMB server.

Comment 5 michael_wardle 1999-10-26 01:31:59 UTC
After you said the the flags had changed, I thought that I would
double check the man pages to find out what they were.

The solution was as simple as specifying -I 172.22.6.51 in addition to
the other parameters.

Both commands now work fine.  Sorry for the inconvenience.


Note You need to log in before you can comment on or make changes to this bug.