Bug 623306 - gdesklet-SlideShow may need to be rebuilt against Python 2.7 in F14 and rawhide
gdesklet-SlideShow may need to be rebuilt against Python 2.7 in F14 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdesklet-SlideShow (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On: 623233
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-11 14:31 EDT by Dave Malcolm
Modified: 2010-08-23 22:01 EDT (History)
1 user (show)

See Also:
Fixed In Version: gdesklet-SlideShow-0.9-8.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 22:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-11 14:31:51 EDT
This is an automatically-filed bug.

gdesklet-SlideShow-0.9-7.fc12 contains one or more .pyc files, but has not been rebuilt since Python 2.7 was built for Fedora, and thus the .pyc files presumably are for Python 2.6.  Python 2.7 changed the bytecode format, so usage of those files will typically fail (see e.g. bug 621726).

The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

I'm sorry that this component was not handled by the mass rebuild.  (This may be due to bug 623233)
Comment 1 MERCIER Jonathan 2010-08-11 14:52:10 EDT
ok i will do an update, sorry this time i work more on Feature D programming and i miss this package

Thanks for this reply
Comment 2 Fedora Update System 2010-08-11 15:47:08 EDT
gdesklet-SlideShow-0.9-8.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/gdesklet-SlideShow-0.9-8.fc14
Comment 3 Fedora Update System 2010-08-11 15:47:17 EDT
gdesklet-SlideShow-0.9-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gdesklet-SlideShow-0.9-8.fc13
Comment 4 Fedora Update System 2010-08-11 19:21:44 EDT
gdesklet-SlideShow-0.9-9.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/gdesklet-SlideShow-0.9-9.fc14
Comment 5 MERCIER Jonathan 2010-08-11 19:36:38 EDT
why you have re-run  the build?
Comment 6 Dave Malcolm 2010-08-11 20:06:33 EDT
Sorry about that.

I tried to filter out things that were already rebuilt, but it looks like I failed in this case.
Comment 7 Fedora Update System 2010-08-12 00:05:16 EDT
gdesklet-SlideShow-0.9-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdesklet-SlideShow'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gdesklet-SlideShow-0.9-8.fc13
Comment 8 Fedora Update System 2010-08-12 15:44:56 EDT
gdesklet-SlideShow-0.9-9.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdesklet-SlideShow'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gdesklet-SlideShow-0.9-9.fc14
Comment 9 Fedora Update System 2010-08-12 15:55:36 EDT
gdesklet-SlideShow-0.9-8.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gdesklet-SlideShow'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gdesklet-SlideShow-0.9-8.fc14
Comment 10 Fedora Update System 2010-08-19 22:17:58 EDT
gdesklet-SlideShow-0.9-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-08-23 21:24:52 EDT
gdesklet-SlideShow-0.9-9.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-08-23 22:01:47 EDT
gdesklet-SlideShow-0.9-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.