Bug 623307 - gedit may need to be rebuilt against Python 2.7 in F14 and rawhide
gedit may need to be rebuilt against Python 2.7 in F14 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On: 623233
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-11 14:31 EDT by Dave Malcolm
Modified: 2010-08-18 21:20 EDT (History)
1 user (show)

See Also:
Fixed In Version: gnome-panel-2.31.6-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-11 14:31:54 EDT
This is an automatically-filed bug.

gedit-2.31.5-1.fc14 contains one or more .pyc files, but has not been rebuilt since Python 2.7 was built for Fedora, and thus the .pyc files presumably are for Python 2.6.  Python 2.7 changed the bytecode format, so usage of those files will typically fail (see e.g. bug 621726).

The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

I'm sorry that this component was not handled by the mass rebuild.  (This may be due to bug 623233)
Comment 1 Dave Malcolm 2010-08-11 20:23:32 EDT
I tried an automated rebuild, but it failed:
  http://koji.fedoraproject.org/koji/getfile?taskID=2394758&name=build.log

gedit-dbus.c:705:45: error: too few arguments to function 'g_dbus_connection_send_message_with_reply'
/usr/include/glib-2.0/gio/gdbusconnection.h:130:18: note: declared here
Comment 2 Fedora Update System 2010-08-13 14:35:40 EDT
brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14
Comment 3 Fedora Update System 2010-08-16 12:04:40 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, file-roller-2.31.5-2.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-panel totem-pl-parser brasero dconf devhelp epiphany evince file-roller gedit glib2 gnome-bluetooth gnome-user-share gobject-introspection nautilus-sendto seahorse-plugins totem rhythmbox sound-juicer yelp gnome-media'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/brasero-2.31.5-4.fc14,dconf-0.5-2.fc14,devhelp-2.31.6-3.fc14,epiphany-2.30.2-3.fc14,evince-2.31.6.1-1.fc14,file-roller-2.31.5-2.fc14,gedit-2.30.2-2.fc14,glib2-2.25.13-2.fc14,gnome-bluetooth-2.31.6-3.fc14,gnome-user-share-2.30.0-7.fc14,gobject-introspection-0.9.3-1.fc14,nautilus-sendto-2.31.6-3.fc14,seahorse-plugins-2.30.1-3.fc14,totem-2.31.6-2.fc14,yelp-2.30.1-4.fc14,rhythmbox-0.13.0-5.fc14,sound-juicer-2.31.6-1.fc14,gnome-media-2.31.6-1.fc14,gnome-panel-2.31.6-1.fc14,totem-pl-parser-2.30.2-1.fc14
Comment 4 Fedora Update System 2010-08-18 21:18:59 EDT
gnome-panel-2.31.6-1.fc14, totem-pl-parser-2.30.2-1.fc14, brasero-2.31.5-4.fc14, dconf-0.5-2.fc14, devhelp-2.31.6-3.fc14, epiphany-2.30.2-3.fc14, evince-2.31.6.1-1.fc14, gedit-2.30.2-2.fc14, glib2-2.25.13-2.fc14, gnome-bluetooth-2.31.6-3.fc14, gnome-user-share-2.30.0-7.fc14, gobject-introspection-0.9.3-1.fc14, nautilus-sendto-2.31.6-3.fc14, seahorse-plugins-2.30.1-3.fc14, totem-2.31.6-2.fc14, rhythmbox-0.13.0-5.fc14, sound-juicer-2.31.6-1.fc14, file-roller-2.31.90-1.fc14, yelp-2.30.1-4.fc14, gnome-media-2.31.6-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.