This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 623355 - rpmlint may need to be rebuilt against Python 2.7 in F14 and rawhide
rpmlint may need to be rebuilt against Python 2.7 in F14 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On: 623233
Blocks: Python27Rebuild
  Show dependency treegraph
 
Reported: 2010-08-11 14:34 EDT by Dave Malcolm
Modified: 2010-08-24 04:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.99-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 04:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-11 14:34:30 EDT
This is an automatically-filed bug.

rpmlint-0.98-1.fc14 contains one or more .pyc files, but has not been rebuilt since Python 2.7 was built for Fedora, and thus the .pyc files presumably are for Python 2.6.  Python 2.7 changed the bytecode format, so usage of those files will typically fail (see e.g. bug 621726).

The package needs to be rebuilt against python 2.7 in both F14 and devel.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

I'm sorry that this component was not handled by the mass rebuild.  (This may be due to bug 623233)
Comment 1 Fedora Update System 2010-08-11 19:30:05 EDT
rpmlint-0.98-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/rpmlint-0.98-2.fc14
Comment 2 Dave Malcolm 2010-08-11 20:05:18 EDT
Update has been created (rpmlint-0.98-2.fc14) so setting status to MODIFIED
Comment 3 Fedora Update System 2010-08-12 15:45:51 EDT
rpmlint-0.98-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpmlint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/rpmlint-0.98-2.fc14
Comment 4 Fedora Update System 2010-08-19 12:34:12 EDT
rpmlint-0.99-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/rpmlint-0.99-1.fc14
Comment 5 Fedora Update System 2010-08-23 21:33:18 EDT
rpmlint-0.99-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.