Bug 62336 - Kernal Panic after initial installation
Kernal Panic after initial installation
Status: CLOSED DUPLICATE of bug 62206
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-03-29 15:36 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-29 15:36:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-29 15:36:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
After installing Skipjack, kernel panics during pivotroot operation.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Redhat Skipjack on Compaq DL380.
2.Reboot System


Actual Results:  here's the last interesting bits on the screen before the
kernel vomits:

kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Loading cpqarray module
Compaq SMART2 Driver (v 2.4.5)
Found 1 controller(s)
cpqarray: Finding drives on ida0 (Integrated Array)
cpqarray ida/c0d0: blksz=512 nr_blks=17756160
blk: queue c03500a0, I/O limit 4095Mb (mask 0xffffffff)
Partition check:
 ida/c0d0: p1 p2 p3 p4 < p5 p6 p7 >
Loading jbd module
Journalled Block Device driver loaded
Loading ext3 module
Mounting /proc filesystem
Mounting root filesystem
mount: error 2 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Kernel panic:  No init found.  Try passing init= option to kernel.

Expected Results:  Machine should boot fine.  Have no problems with the exact
same setup with Redhat 7.2.

Additional info:

Here's my grub.conf (I was able to go grab it when boot in rescue mode, funny
how that works, eh?) :

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/ida/c0d0p6
#          initrd /initrd-version.img
title Red Hat Linux (2.4.18-0.4)
        root (hd0,0)
        kernel /vmlinuz-2.4.18-0.4 ro root=/dev/ida/c0d0p6
        initrd /initrd-2.4.18-0.4.img
Comment 1 Matt Wilson 2002-04-01 11:07:24 EST

*** This bug has been marked as a duplicate of 62206 ***

Note You need to log in before you can comment on or make changes to this bug.