Bug 62344 - tdfx will not do DRI for Voodoo3
tdfx will not do DRI for Voodoo3
Status: CLOSED DUPLICATE of bug 61090
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 17:15 EST by jmbastia
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-29 17:15:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmbastia 2002-03-29 17:15:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310

Description of problem:
I just tried running some OpenGL programs under Skipjack and the framerate was
about 5 seconds per fram on a Voodoo3.  I checked the /var/log/XFree86.0.log
file, and noticed this line:

  (WW) TDFX(0): [dri] To use DRI, with a 16Mb Voodoo 3 or Banshee 
                card, you must invoke the server using a maximum 
                resolution of 1024x768 or lower.

I currently have over 50 PCs with Voodoo3 cards running RedHat 7.1 and 7.2, and
all of them are running at 1280x1024 at 16bpp, and DRI works beautifully.

Why does the tdfx driver for XFree86 4.2.0 have this new requirement when it
worked fine before?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure XFree86 to run at 1280x1024x16bpp
2. Fire up X
3. Note the warning in /var/log/XFree86.0.log
4. Try to run any OpenGL program and note the horrible performance
	

Actual Results:  the tdfx driver refused to use DRI

Expected Results:  the tdfx driver should enable DRI

Additional info:
Comment 1 Mike A. Harris 2002-03-31 07:19:00 EST

*** This bug has been marked as a duplicate of 61090 ***

Note You need to log in before you can comment on or make changes to this bug.