Bug 62346 - Bad SSL Performance with Broadcom 5820
Bad SSL Performance with Broadcom 5820
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-29 18:30 EST by Michael E Brown
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-10 21:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Candidate patch for mod_ssl slowdowns. (818 bytes, patch)
2002-04-09 14:41 EDT, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Michael E Brown 2002-03-29 18:30:14 EST
Description of Problem:
Performance of SSL with the Broadcom SSL card should be in the neighborhood of
700 Req/sec, but performance with Beta3 is half of this. Note from Nasser
Iranikhah <niran@broadcom.com>: 

"On the same machine when I build the apache based on
openssl-0.9.6c/mod_ssl_2.8.5-1.3.22/apache_1.3.22 I get over 700 Req/sec using
the same driver."

This is currently being discussed on the (private) bcm5820-impl-list@redhat.com. 

A note from Jimmy Ruane <jruane@broadcom.com>:

> 4) Performance is still 1/2 where it should be.
---cut--
> Regarding 4) we believe the problem is with Apache. We are speculating
> a debug version may be running.
Comment 1 Need Real Name 2002-04-01 12:23:37 EST
I got ~770 R/s when I ran 20 parallel sessions of  "speed rsa1024 -engine ubsec" under openssl-0.9.6c or the one that comes with beta3.   This 
should prove that openssl is okay, the problem may reside in apache.
Comment 2 Bill Nottingham 2002-04-01 15:52:36 EST
Do you have the i386 or i686 openssl installed?
Comment 3 Need Real Name 2002-04-03 16:31:40 EST
I am not sure if I undrestand the question!  I downloaded the openssl-0.9.6c 
and compiled it on my Dell PowerEdge 2500 with 2x1000MHz CPU and compared with 
the openssl that was installed from the Beta3 distrobution.
Comment 4 Nalin Dahyabhai 2002-04-03 18:23:50 EST
Specifically, what is the output of:
rpm -q --queryformat '%{arch}\n' openssl
?
Comment 5 Need Real Name 2002-04-03 21:48:21 EST
It is i686.
Comment 6 Nalin Dahyabhai 2002-04-05 03:20:44 EST
To determine if the problem truly is apache, please compare the packaged 1.3.23
with 1.3.23 built from source (not version 1.3.22 listed above).

When you build 1.3.23 from source, do the figures match up with the 1.3.23
package, or with the 1.3.22 source build?
Comment 7 Need Real Name 2002-04-05 12:48:46 EST
Per Howard' test here are the results:

with SW only (and using apache go with RH beta4):
performance: ~110 request/s

With SW only: (and using apache that I manually build)
apache-1.3.22 : ~270 request/s
apache-1.3.23 : ~174 request/s

I just downloaded the latest RH8.0 beta4 and the performance is still bad.
Here is what I found:
with RH7.2 released, it using apache-1.3.22  ==> performance: 760
request/s
with RH8.0 beta3&4 , it using apache-1.3.23  ==> performance: 400
request/s
If I compile apache-1.3.22  ==> performance: 760 request/s
If I compile apache-1.3.23  ==> performance: 400 request/s

so look like the performance issue is relate to the new Apache version
1.3.23

Comment 8 Nalin Dahyabhai 2002-04-09 14:41:17 EDT
Created attachment 52904 [details]
Candidate patch for mod_ssl slowdowns.
Comment 9 Nalin Dahyabhai 2002-04-09 14:41:54 EDT
Please try the patch for mod_ssl I've just attached and see if that helps.
Comment 10 Need Real Name 2002-04-10 21:14:08 EDT
As per Howard testing:

I applied the patch into mod_ssl-2.8.7-1.3.23 and compiled using
apache_1.3.23.  here is what I got:
with 5820, performance ~746 request/second.
with SW only, performance ~271 request/second.

This is the normal performance we were expecting.  I hope this change gets 
through the RC1.

Thank you for all your help.
Comment 11 Nalin Dahyabhai 2002-04-11 10:00:28 EDT
The fix is merged into mod_ssl-2.8.7-4.  Closing.

Note You need to log in before you can comment on or make changes to this bug.