Bug 623488 - SELinux is preventing /usr/bin/webalizer access to a leaked /root file descriptor.
SELinux is preventing /usr/bin/webalizer access to a leaked /root file descri...
Status: CLOSED DUPLICATE of bug 621842
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:4b84bb37e53...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 18:09 EDT by David
Modified: 2010-08-17 22:57 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 14:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2010-08-11 18:09:44 EDT
Summary:

SELinux is preventing /usr/bin/webalizer access to a leaked /root file
descriptor.

Detailed Description:

[webalizer has a permissive type (webalizer_t). This access was not denied.]

SELinux denied access requested by the webalizer command. It looks like this is
either a leaked descriptor or webalizer output was redirected to a file it is
not allowed to access. Leaks usually can be ignored since SELinux is just
closing the leak and reporting the error. The application does not use the
descriptor, so it will run properly. If this is a redirection, you will not get
output in the /root. You should generate a bugzilla on selinux-policy, and it
will get routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:webalizer_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        webalizer
Source Path                   /usr/bin/webalizer
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           webalizer-2.21_02-3
Target RPM Packages           filesystem-2.4.31-1.fc13
Policy RPM                    selinux-policy-3.7.19-44.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.2-34.fc13.i686.PAE
                              #1 SMP Thu Aug 5 23:16:07 UTC 2010 i686 i686
Alert Count                   4
First Seen                    Sun 08 Aug 2010 03:31:01 AM EST
Last Seen                     Thu 12 Aug 2010 03:14:01 AM EST
Local ID                      156d9d39-519b-4c65-9715-e20cf085c1dd
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1281546841.461:39347): avc:  denied  { read } for  pid=2093 comm="webalizer" path="/root" dev=dm-0 ino=268 scontext=system_u:system_r:webalizer_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1281546841.461:39347): arch=40000003 syscall=11 success=yes exit=0 a0=85e1bb8 a1=85e3cf8 a2=85e3f60 a3=85e3cf8 items=0 ppid=2088 pid=2093 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=454 comm="webalizer" exe="/usr/bin/webalizer" subj=system_u:system_r:webalizer_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,webalizer,webalizer_t,admin_home_t,dir,read
audit2allow suggests:

#============= webalizer_t ==============
allow webalizer_t admin_home_t:dir read;
Comment 1 Miroslav Grepl 2010-08-12 07:54:18 EDT
Do you run webalizer from cron?

I will add

userdom_dontaudit_list_admin_dir(admin_home_t)
Comment 2 Daniel Walsh 2010-08-12 16:48:26 EDT
I think cronnie is leaking an open file descriptor to /root

We have seen the same AVC appear in prelink and webalizer, both tools run from cron.
Comment 3 Daniel Walsh 2010-08-13 14:48:45 EDT

*** This bug has been marked as a duplicate of bug 621842 ***

Note You need to log in before you can comment on or make changes to this bug.