Bug 623512 - Broadcast doesn't work fine
Broadcast doesn't work fine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: terminator (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 21:32 EDT by Chao Ye
Modified: 2010-12-13 16:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 16:51:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of three steps. (484.44 KB, application/x-gzip)
2010-08-30 21:39 EDT, Chao Ye
no flags Details

  None (edit)
Description Chao Ye 2010-08-11 21:32:32 EDT
Description of problem:
Broadcast doesn't work fine.

Version-Release number of selected component (if applicable):
terminator-0.94-1

How reproducible:
Open broadcast group, then type.

Steps to Reproduce:
1.Make a new group, just call the group Test
2.Let another window or tab join the group, call it WindowB
3.Typing in one grouped window/tab, call it WindowA
  
Actual results:
WindowA works fine, WindowB doesn't. Typed 'a' in WindowA, there will be 'aa' in 
WindowB. Each type will repeated twice in other windows/tabs.

Expected results:
WindowA & WindowB both work fine.

Additional info:
I tried Broadcast All, it also have the same problem.
Comment 1 Dominic Hopf 2010-08-28 09:46:01 EDT
Hey,
sorry for my delayed response. I just was about trying to reproduce this issue with the new Terminator 0.95 I already installed here. I actually am not able (or don't understand) to add another Window or Tab to an existing group.

Could you give a more detailed description on how to do that?

I tried drag'n'drop, thus if you were also working with drag'n'drop, then maybe the issue already is fixed in 0.95. Anyway, you can update via `yum -y update terminator --enablerepo=updates-testing`. :)

Regards,
Dominic
Comment 2 Chao Ye 2010-08-29 21:37:45 EDT
Hi,
I tried with the latest terminator. And the bug seems didn't fixed.
-------------------------------------------------------------
[derek@dhcp-65-75 ~]$ rpm -q terminator
terminator-0.95-1.fc13.noarch
-------------------------------------------------------------
Steps to Reproduce:
1. Split your window(Shift+Ctrl+O or Shift+Ctrl+E)
2. Set Broadcast(Click the left icon of one split window, choose Broadcast all, you'll find the other window's tab bar will change to blue)
3. Type any character

Regards,
ChaoYe
Comment 3 Dominic Hopf 2010-08-30 13:51:10 EDT
I actually can not reproduce the issue with the steps you describe. Today I stumbled over an issue which is at least similar to yours, but I'm not sure if it is exactly the same. What I am doing is opening another Terminator window running in the same instance/process via Ctrl+Shift+I. Terminator doesn't seem to bother then, if one of the windows in this instance is splitted or not... the effect seems to be the same.

Is this the behaviour you mean?

By the way, I assume you also have the latest version of vte installed?
Comment 4 Chao Ye 2010-08-30 21:39:44 EDT
Created attachment 442074 [details]
Screenshot of three steps.
Comment 5 Chao Ye 2010-08-30 21:45:16 EDT
I have the latest version of vte installed.
----------------------------------------------------------------
[derek@dhcp-65-75 ~]$ rpm -q vte
vte-0.24.1-1.fc13.x86_64
----------------------------------------------------------------
To reproduce the issue, you should Split via Ctrl+Shift+O/Ctrl+Shift+E *NOT* Ctrl+Shift+I which is create a new window.
And I found that when broadcast between two windows, it seems the key release have some problem. When I press a key, like 'a', the two windows will print 'aaaaaaaaaa', and never stop.
Comment 6 Dominic Hopf 2010-12-11 16:52:22 EST
Hi ChaoYe,

I'm very sorry for my spare time the last weeks. In the meantime I tried a felt thousand times to reproduce this issue. On my home PC as well as at work. I'm still not able to reproduce it.

Is this issue still present for you? If yes, would it be possible to send/attach your configuration (~/.config/terminator/config) to maybe point out if there is any special setting which causes this? :)

Thanks very much in advance & Regards
Comment 7 Chao Ye 2010-12-12 21:46:46 EST
Hi Dominic,

I'm currently F14. Just tried this again, broadcast works fine:-)
[cye@dhcp-65-138 tier1]$ rpm -q terminator
terminator-0.95-2.fc14.noarch
I think it's fine to close this issue.
Comment 8 Dominic Hopf 2010-12-13 16:51:30 EST
Thanks very much for your feedback ChaoYe, closing this issue then. :)

Note You need to log in before you can comment on or make changes to this bug.