Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 623513 - GDM fails to log in if ck-history is too slow
GDM fails to log in if ck-history is too slow
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 21:39 EDT by Ray Strode [halfline]
Modified: 2010-11-10 15:28 EST (History)
3 users (show)

See Also:
Fixed In Version: gdm-2.30.4-21.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:28:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 626564 None None None Never

  None (edit)
Description Ray Strode [halfline] 2010-08-11 21:39:04 EDT
We got an report upstream from Canonical about GDM not working properly for some of their users.  It would never show a login screen for those users.

I spent a few hours debugging the issue with them and determined GDMs "watchdog" handling code (which kills ck-history after a timeout) is missing a line of code to zero out its process id after killing the process.  This missing line prevents GDM from working properly.

This is probably a blocker issue because it means that after months of accumulated use (when the history file gets big) GDM will just stop working.

I've fixed this upstream here:

http://git.gnome.org/browse/gdm/commit/?h=gnome-2-30&id=285d6dda3ee0439349cca22346efef3392d66d48

and got confirmation from several Ubuntu users hit by the issue that the fix works for them.

Artificially reproducing the problem is fairly straight forward:


1) Replace ck-history with a thin shell script wrapper that adds an artificial delay
# mv /usr/bin/ck-history /usr/bin/ck-history.binary

cat > /usr/bin/ck-history << EOF
#!/bin/sh
sleep 5
exec /usr/bin/ck-history.binary "$@"
EOF
chmod +x /usr/bin/ck-history

2) Reboot

At this point the GDM greeter will never load
Comment 1 Ray Strode [halfline] 2010-08-12 13:08:15 EDT
This is building now.
Comment 2 Vladimir Benes 2010-08-16 10:39:49 EDT
tested using instructions above .. gdm shows user list even after 5 second delay
-> VERIFIED
Comment 3 Vladimir Benes 2010-08-16 10:40:58 EDT
gdm-2.30.4-21.el6 tested from latest build
Comment 4 releng-rhel@redhat.com 2010-11-10 15:28:21 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.