Bug 62352 - can't run IglooFTP under kernel-2.4.18-0.12.i686.rpm
can't run IglooFTP under kernel-2.4.18-0.12.i686.rpm
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-29 22:10 EST by R.K.Aa.
Modified: 2016-11-24 10:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 15:50:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R.K.Aa. 2002-03-29 22:10:30 EST
IglooFTP PRO doesn't start under rawhide kernel 2.4.18-0.12
This appears in console:

IglooFTP-PRO: dynamic-link.h:57: elf_get_dynamic_info: Assertion `! "bad dynamic
tag"' failed.

I wonder if this has to do with the relase comment found at
http://www.kernel.org/pub/linux/kernel/v2.4/ChangeLog-2.4.18:

"Update: The SET_PERSONALITY fix in rc4 has _not_
been included in the final 2.4.18 by mistake."

The only rc4 change was, still according to Changelog:
"- Load code did not set personality for
  binaries without an interpreter: This was 
  breaking static apps on several archs"


Version-Release number of selected component (if applicable):
System is based around RH7.2 with all errata updates.
(P4 1.80A). Only "unorthodox" upgrade was to the rawhide kernel and glibc today

How Reproducible:
Always

Steps to Reproduce:
1. Install static version of IglooFTP PRO (
http://iglooftp.com/linux/download.html )
2. Install current rawhide kernel and glibc files
3. Try to run IglooFTP PRO

Actual Results:
No go

Expected Results:
Start as it used to
Comment 1 R.K.Aa. 2002-03-29 22:53:25 EST
I notice that all Crossover plugins also fail to load now.
Comment 2 Arjan van de Ven 2002-03-30 03:18:39 EST
The set personality bug doesn't affect i386/athlon architectures and is fixed
anyway.
Comment 3 Jakub Jelinek 2002-03-30 12:55:14 EST
Yes, this is a problem, but not in the glibc we ship, but in glibc which
was installed on the box where iglooftp was compiled.
I can remove the dynamic tag from ld.so for now at the cost of some performance
regression, but definitely will not do it indefinitely (ie. for the next
release using broken static binaries simply will not work.
Comment 4 R.K.Aa. 2002-03-30 14:07:09 EST
I've bought RedHat Linux since 4.2 but have never taken advantage of the support
programs, so allow me this opportunity to vent a little:

The reason i upgraded was in a hope that the frequent system lockups with SiS
PCI controllers had been solved - but they haven't. Meaning i can't use a
Hauppauge TV card on Linux with a new Abit SD7-533. Being able to use the TV
card on Linux was what made me decide to port 100% to Linux in the first place,
in '98/'99. Where that card goes, I go. 

I bought IglooFTP PRO, the Crossover plugin from Codeweavers, 10 games from Loki
when they got in trouble, Ximian Desktop etc. etc. etc. Even CorelDraw. The
Crossover plugin is only weeks old. To me, at least, it would definately be a
greater "performance regression" to trash most of the software i purchased.

The alternative - never upgrade - wouldn't really take me anywhere either. I
need the PCI fix. I've installed XP for now till that issue is solved,
Hauppauge's driver for the TV card has a PCI lockup workaround (probably
prevents write-through on the TV cards slot). XP turned out to be an extremly
uncomfortable OS however - a shitload of spyware, oversized widgets and a
suprisingly striking "beta quality" feel. I miss my X sorely and am a *very*
unhappy RH user today.

As a single stupid consumer I probably don't belong in the RH target group, but
if the software side of this can be quickly cured with a "compat lib", I'd like
to know how to go about it. Thank you.
Comment 5 R.K.Aa. 2002-03-30 14:47:38 EST
I assume the Loki games are unlikely to be recompiled since Loki went out of
business. SimCity 3000 fails, amongst others:

./sc3u: symbol _dl_global_scope, version GLIBC_2.0 not defined in file
ld-linux.so.2 with link time reference

I see in bug 62357 that vmware now also fail to run with glibc 2.2.5
Comment 6 Jakub Jelinek 2002-03-30 15:03:42 EST
Bug 62357 is VMWare bug (they apparently haven't read nice(2) man page),
current glibc compiles to what SuS requires (as well as LSB and other standards).
SimCity 3000 failure above looks like Loki bug, they have no business using
glibc internal interface. An Operating System cannot be just huge pile of
workarounds for low quality binary only third party stuff. VMWare will be fixed
AFAIK. The bad dynamic tag failure is more problematic.
If such static apps using dynamic linking are to be supported, it means
no dynamic tags other than that old glibc recognized can be used, ever.
This is big limitation because someone used incorrectly compiled glibc
to link the static binary against (I must add, shipping third party programs
as static binaries is almost always a very bad idea; if a fully dynamically
linked program is not possible, using -Bstatic for libs other than the standard
ones and -Bdynamic for the rest is the preferred way), as it would e.g. mean
prelinking cannot be ever used (which can cut dynamic program loading times
drastically).
Comment 7 Jakub Jelinek 2002-04-11 12:14:20 EDT
IglooFTP should work with glibc-2.2.5-32 just fine.
Comment 8 R.K.Aa. 2002-05-18 10:51:26 EDT
Regarding earlyer comments:
Surely known by now but for the record: Crossover, SimCity 3000, Quake3,
IglooFTP-PRO - all work fine after i upgraded to glibc-2.2.5-34 (both Crossover
and Igloo was working again already in 2.2.5-32)

Unrelated: Severe problems with the SiS chipsets and PCI/v4l remains
(Abit SD7-533, kernel-2.4.18-0.12)

Note You need to log in before you can comment on or make changes to this bug.