Bug 623521 - [abrt] crash in picard-0.12.1-1.fc12: script.py:70:eval:TypeError: func_lower() takes exactly 2 arguments (4 given)
[abrt] crash in picard-0.12.1-1.fc12: script.py:70:eval:TypeError: func_lower...
Status: CLOSED DUPLICATE of bug 623517
Product: Fedora
Classification: Fedora
Component: picard (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
abrt_hash:757957b0
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 22:52 EDT by jason.prokopowich
Modified: 2010-08-25 02:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 02:55:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.78 KB, text/plain)
2010-08-11 22:52 EDT, jason.prokopowich
no flags Details

  None (edit)
Description jason.prokopowich 2010-08-11 22:52:12 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/picard
component: picard
executable: /usr/bin/picard
kernel: 2.6.32.16-150.fc12.x86_64
package: picard-0.12.1-1.fc12
reason: script.py:70:eval:TypeError: func_lower() takes exactly 2 arguments (4 given)
release: Fedora release 12 (Constantine)

backtrace
-----
script.py:70:eval:TypeError: func_lower() takes exactly 2 arguments (4 given)

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/picard/ui/options/renaming.py", line 71, in check_formats
    self.update_examples()
  File "/usr/lib64/python2.6/site-packages/picard/ui/options/renaming.py", line 97, in update_examples
    example1 = self._example_to_filename(self.example_1())
  File "/usr/lib64/python2.6/site-packages/picard/ui/options/renaming.py", line 89, in _example_to_filename
    filename = file._make_filename(file.filename, file.metadata, settings)
  File "/usr/lib64/python2.6/site-packages/picard/file.py", line 228, in _make_filename
    new_filename = self._script_to_filename(format, metadata, settings)
  File "/usr/lib64/python2.6/site-packages/picard/file.py", line 200, in _script_to_filename
    filename = ScriptParser().eval(format, metadata, self)
  File "/usr/lib64/python2.6/site-packages/picard/script.py", line 237, in eval
    return ScriptParser._cache[key].eval(self)
  File "/usr/lib64/python2.6/site-packages/picard/script.py", line 80, in eval
    result.append(item.eval(state))
  File "/usr/lib64/python2.6/site-packages/picard/script.py", line 70, in eval
    return function(parser, *args)
TypeError: func_lower() takes exactly 2 arguments (4 given)

Local variables in innermost frame:
function: <function func_lower at 0x7f6b580507d0>
eval_args: True
self: <ScriptFunction $lower([[<ScriptFunction $if2([[<ScriptVariable %albumartist%>], [<ScriptVariable %artist%>]])>, u'/', <ScriptVariable %album%>, u'/', <ScriptFunction $num([[<ScriptVariable %tracknumber%>], [u'2']])>, u' ', <ScriptVariable %title%>], [u' '], [u'_']])>
args: [u'The Beatles/Help!/07 Ticket to Ride', u' ', u'_']
parser: <picard.script.ScriptParser object at 0x1da1750>
arg: [u'_']

How to reproduce
-----
1.updating directory/file path saving properties
2.
3.
Comment 1 jason.prokopowich 2010-08-11 22:52:15 EDT
Created attachment 438327 [details]
File: backtrace
Comment 2 Alex Lancaster 2010-08-25 02:55:52 EDT
This seems to be a duplicate of bug #623517.

*** This bug has been marked as a duplicate of bug 623517 ***

Note You need to log in before you can comment on or make changes to this bug.