Bug 623523 - Wrong size of video memory setting in guest
Wrong size of video memory setting in guest
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-11 23:12 EDT by Nan Zhang
Modified: 2010-08-23 01:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 01:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Windows VRAM size (207.04 KB, image/png)
2010-08-11 23:12 EDT, Nan Zhang
no flags Details
Xorg.0.log for cirrus (23.86 KB, text/x-log)
2010-08-11 23:19 EDT, Nan Zhang
no flags Details

  None (edit)
Description Nan Zhang 2010-08-11 23:12:38 EDT
Created attachment 438332 [details]
Windows VRAM size

Description of problem:
Inconsistent VRAM between guest and XML definition.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.109.el6.x86_64
libvirt-0.8.1-23.el6.x86_64
kernel-2.6.32-59.1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
Set video ram in guest:
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
  
Actual results:
On Linux guest:
(II) VESA(0): VESA VBE Total Mem: 16384 kB

On Windows guest:
Memory Size: 4 MB

Expected results:
The guest video memory should be consistent with specified.

Additional info:
Attached log and screenshot for reference.
Comment 1 Nan Zhang 2010-08-11 23:19:04 EDT
Created attachment 438333 [details]
Xorg.0.log for cirrus
Comment 3 RHEL Product and Program Management 2010-08-11 23:38:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Nan Zhang 2010-08-12 00:36:46 EDT
Sorry, I put a wrong number for linux guest, the correct size as following.

On Linux guest:
...
(II) VESA(0): VESA VBE Total Mem: 4096 kB
...
Comment 5 Daniel Veillard 2010-08-13 10:49:45 EDT
I don't think it's a bug. We looked at it actually while I was in Beijing,
and the driver on XOrg for cirrus was always limiting the memory to 4MB.
I would not be surprized if the driver on Windows didn't do the same, because
all real cirrus logic based card only had 4MB of memory at the maximum.
And from my recollection of the mid-90's a graphic card like this with
4MB was rather high-end, then other chipset were developped taking advantage
of more memory.

So I think this is a limitation of the Cirrus Logic drivers both for Linux
and Windows, I don't think it's a libvirt bug actually. In any case I don't
see this fixed at the libvirt level or for 6.0

Daniel
Comment 6 Nan Zhang 2010-08-16 02:52:52 EDT
Daniel,

But the value vram='9216' doesn't make sense in XML description, if we should make some changes in XML to corresponding with the real allocated memory size?

Thanks,
Neil
Comment 7 Daniel Berrange 2010-08-16 06:39:24 EDT
This is a known limitation of the Cirrus card in QEMU, you can't change the VRAM. This bit of XML was added for the SVGA and SPICE QXL cards which are configurable. Hopefully we can make Cirrus configurable too in the future.
Comment 8 Nan Zhang 2010-08-23 01:38:07 EDT
OK, thanks for the explanation! Close it with NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.