Bug 623524 - Err during filesystem check after upgrading bootloader
Err during filesystem check after upgrading bootloader
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-08-11 23:19 EDT by MingtaoNiu
Modified: 2010-09-09 18:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-09 18:58:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Err during filesystem check after upgrading bootloader (29.46 KB, image/png)
2010-08-11 23:19 EDT, MingtaoNiu
no flags Details
Err during filesystem check after upgrading bootloader (3.35 KB, application/x-bzip)
2010-08-13 00:26 EDT, MingtaoNiu
no flags Details
all log files in /tmp after updating bootloader (36.00 KB, application/x-gzip)
2010-09-05 23:23 EDT, MingtaoNiu
no flags Details

  None (edit)
Description MingtaoNiu 2010-08-11 23:19:28 EDT
Created attachment 438334 [details]
Err during filesystem check after upgrading bootloader

Description of problem:

An ERR occurred during filesystem check after upgrading form F13 to F14 while creating a new bootloader configuration

Version-Release number of selected component (if applicable):
anaconda 14.15
F14-alpha-rc3

How reproducible:
100%

Steps to Reproduce:
1.Perform a default installation of the previous release ( Fedora 13)
2.Boot the current release (Fedora 14) using any available means (boot.iso)
3.Select appropriate language and keyboard, then select Upgrade an existing installation
4.Select Create new boot loader configuration to update
5.After upgrade finished, reboot the system 
  
Actual results:
An ERR occurred during filesystem check
Detail info is in the attachment

Expected results:
   1.  The system should be upgraded to new version without error
   2. The system can boot into new version fedora without error
   3. The opened terminal, file browser, or other system applications should display and work correctly 

Additional info:
Comment 1 Chris Lumens 2010-08-12 13:50:41 EDT
Please attach all the /var/log/anaconda* files to this bug report.
Comment 2 MingtaoNiu 2010-08-13 00:26:28 EDT
Created attachment 438585 [details]
Err during filesystem check after upgrading bootloader
Comment 3 He Rui 2010-08-18 05:36:01 EDT
Mark as Beta blocker according to:

The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation of the previous stable Fedora release, either via preupgrade or by booting to the installer manually
Comment 4 Brian Lane 2010-08-25 12:29:50 EDT
There should be more logs than just anaconda.log and anaconda-yum.log

[bcl@lister tmp]$ ls /var/log/anaconda.*
/var/log/anaconda.log          /var/log/anaconda.syslog
/var/log/anaconda.program.log  /var/log/anaconda.xlog
/var/log/anaconda.storage.log  /var/log/anaconda.yum.log
Comment 5 Adam Williamson 2010-08-27 12:48:08 EDT
Discussed at today's blocker review meeting. This seems a clear blocker on the criterion cited. Accepted as Beta blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2010-09-03 11:52:23 EDT
Hurry / Ming Tao, can you attach the extra logs Brian asked for?
Comment 7 MingtaoNiu 2010-09-05 23:23:42 EDT
Created attachment 443214 [details]
all log files in /tmp after updating bootloader

I couldn't get log files after rebooting because of the filesystem error.
I got the log files in /tmp before rebooting.
Comment 8 John Poelstra 2010-09-09 00:34:46 EDT
What are the plans for addressing and assessing this bug?  We'd love to have more information before the next blocker meeting this Friday.
Comment 9 Brian Lane 2010-09-09 11:51:41 EDT
I'll try to reproduce this.
Comment 10 Brian Lane 2010-09-09 18:58:12 EDT
I did a test using an updated F13 KVM virt. I upgraded using the full Alpha DVD and the Alpha netboot.iso and saw no problems with filesystem errors. Problems like that are more likely to be an issue with the local system's hardware than with Anaconda.

Note You need to log in before you can comment on or make changes to this bug.