Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 623543 - Installation Guide documents incorrect usage of driver disc on USB and through network
Installation Guide documents incorrect usage of driver disc on USB and throug...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.0
All Linux
urgent Severity high
: rc
: ---
Assigned To: Ruediger Landmann
ecs-bugs
: Documentation, Reopened, RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 00:56 EDT by Chao Yang
Modified: 2013-07-11 20:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:30:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chao Yang 2010-08-12 00:56:38 EDT
Description of problem:
driver disc load from USB storage failed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Prepare a boot.iso with busybox tool in it, and burn it to a blank CD.
2. Prepare driver disc on a USB flash drive with "dd if=/path/to/your/dd.iso of=/your/USB".
3. Boot a physical machine from the CDROM, with the command "linux dd".
4. Try to load the driver from USB flash drive.
  
Actual results:
Ask for "Select driver disk image" from the USB drive. It only contains the content of the driver disk image. Driver load failed.

Expected results:
The updated driver can be load from USB storage.

Additional info:
I have also tried to burn the same driver on to a CD, and load it in the boot time, driver got updated successfully.

Best,
Chao
Comment 2 RHEL Product and Program Management 2010-08-12 01:18:33 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Jon Masters 2010-08-16 13:44:28 EDT
The load from USB is supposed to be the .iso file *on* the USB. So you need to have a formatted, normal USB stick, then copy the .iso file onto it. It can also be compressed I think. You don't dd it onto the device. Please re-open if necessary.

Jon.
Comment 4 Chao Yang 2010-08-16 22:54:08 EDT
Then I think we should update the RHEL 6 beta Installation guide. Cause it says that the driver update disk has been supported on USB devices.
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/sect-Preparing_for_a_driver_update_during_installation-x86.html

########################################################################
Methods that use the image file itself

        * local hard drive
        * USB storage device (for example, USB flash drive)
        * network (HTTP, FTP, NFS) 

Methods that use a driver update disk produced from an image file

        * CD
        * DVD
        * USB storage device (for example, USB flash drive) 
########################################################################

Best,
Chao
Comment 5 Chris Lumens 2010-08-17 09:12:43 EDT
Please attach /tmp/syslog and /tmp/anaconda.log to this bug report.  There's really nothing for us to go on here except "I tried to do this and it didn't work", which is not very descriptive.
Comment 6 Jon Masters 2010-08-17 13:56:44 EDT
Chao: did you see my comment 3? I explained there why it won't work to just dd onto a USB stick. You need to *copy* the .iso file onto the formatted stick (just a plain old stick with an existing vfat filesystem).
Comment 7 Chao Yang 2010-08-19 10:40:07 EDT
Yes, Jon is right. Copied dd.img file to the USB stick lead to driver update successfully. In this case, I'd like to close this bug.

In my opinion, we should update the Installation guide.

Best,
Chao
Comment 8 Jon Masters 2010-08-19 14:50:55 EDT
Chao: can you work with Rudi to do the install guide fix? I will ping him now.

Jon.
Comment 9 David Cantrell 2010-08-19 16:50:49 EDT
(In reply to comment #8)
> Chao: can you work with Rudi to do the install guide fix? I will ping him now.
> 
> Jon.

I think it's too late for changing the install guide, but we can add a technical note.  Just add the content to the "Technical Note" field in this bug and ping Rudi.
Comment 10 Jon Masters 2010-08-19 16:54:41 EDT
I sent email to Rudi, copied Chao, and the DUP6 devel list.
Comment 11 Jon Masters 2010-08-20 14:47:11 EDT
No word back from Rudi. I'll ping next week.
Comment 12 Ruediger Landmann 2010-08-20 20:21:44 EDT
Reopening against Install Guide -- this is small enough for me to fix for GA --
sorry for the delay, Jon, I was sure I'd updated this bug yesterday morning :/
Comment 13 Jon Masters 2010-08-21 00:47:31 EDT
Thanks a whole bunch, Rudi. No problem for "delay" (hardly a delay!). I'm just happy if we can get this all taken care of for GA :)

Jon.
Comment 14 Ruediger Landmann 2010-08-21 09:48:11 EDT
    Removed USB from "Methods that use a driver update disk produced from an image
    file" in "6.2. Preparing for a driver update during installation"

    Removed section "6.2.2.2. Creating a driver update disk on USB storage device"
    that detailed using dd to transfer the files from the image to a USB drive. 

    Fixed in build 0-90
Comment 15 Jon Masters 2010-08-21 17:37:54 EDT
Can you send me a link to the updated documentation?
Comment 16 Ruediger Landmann 2010-08-21 18:20:15 EDT
(In reply to comment #15)
> Can you send me a link to the updated documentation?

No problem :)

Latest versions of all docs are always available on the Documentation Stage:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/
Comment 17 Jon Masters 2010-08-21 23:57:28 EDT
Thanks
Comment 18 Jon Masters 2010-08-21 23:57:49 EDT
Oh and hey, thanks for doing this on the weekend :)
Comment 19 Michael Doyle 2010-08-23 00:01:27 EDT
Rudi,

You will also need to remove the reference to it in the section below.

6.2.2. Preparing a driver disc
You can create a driver update disk on CD, DVD, or a USB storage device such as a USB flash drive. 

Red_Hat_Enterprise_Linux-Installation_Guide-6-en-US-0-91
Comment 20 Chao Yang 2010-08-23 01:26:34 EDT
I think we should also consider the network issue. My suggestion is to remove the "on a FTP, HTTP, or NFS server on your local network (or take note of a location on the Internet where someone else has placed the ISO image file) ". And add "PXE/TFTP server contains the ISO image file". For detail info, please refer to bug 621043.

What's your opinion, Jon? 

Best,
Chao
Comment 21 Ruediger Landmann 2010-08-23 02:45:20 EDT
(In reply to comment #20)
> I think we should also consider the network issue. My suggestion is to remove
> the "on a FTP, HTTP, or NFS server on your local network (or take note of a
> location on the Internet where someone else has placed the ISO image file) ".
> And add "PXE/TFTP server contains the ISO image file". For detail info, please
> refer to bug 621043.
> 
> What's your opinion, Jon? 
> 
> Best,
> Chao

1. Can you no longer load a driver disk from a FTP, HTTP, or NFS location in RHEL6?

2. Does "6.2.3. Preparing an initial RAM disk update" no longer describe the correct procedure to provide a driver update from a PXE server?

Cheers,
Rudi
Comment 22 Chao Yang 2010-08-23 04:02:32 EDT
(In reply to comment #21)
> (In reply to comment #20)
> > I think we should also consider the network issue. My suggestion is to remove
> > the "on a FTP, HTTP, or NFS server on your local network (or take note of a
> > location on the Internet where someone else has placed the ISO image file) ".
> > And add "PXE/TFTP server contains the ISO image file". For detail info, please
> > refer to bug 621043.
> > 
> > What's your opinion, Jon? 
> > 
> > Best,
> > Chao
> 
> 1. Can you no longer load a driver disk from a FTP, HTTP, or NFS location in
> RHEL6?
> 

Yes, we can not load a driver disk from FTP/HTTP/NFS in RHEL6.


> 2. Does "6.2.3. Preparing an initial RAM disk update" no longer describe the
> correct procedure to provide a driver update from a PXE server?
> 

Here is my thought:
I am not sure about the procedure here whether works, I use another way during my testing which works fine. It has been described in the link: http://intranet.corp.redhat.com/ic/intranet/AnacondaInitrdUpdate.html. 
And also it's easy, not so many steps. Can we just change for that way? 

Replace step 2 to step 7 in 6.2.3 with the following 2 steps: 
######################################################
2. Extract the initrd.img to a folder, e.g /tmp/initrd_update/. 

3. Copy the dd.iso file to the extracted initrd.img folder. 
$ cp dd.iso /tmp/initrd_update/dd.img
#######################################################

> Cheers,
> Rudi


Best,
Chao
Comment 23 Ruediger Landmann 2010-08-23 09:19:19 EDT
(In reply to comment #22)

> Yes, we can not load a driver disk from FTP/HTTP/NFS in RHEL6.

Thanks Chao -- 

In build 0-92, I have removed all references to loading a driver update through HTTP/FTP/NFS.

> > 2. Does "6.2.3. Preparing an initial RAM disk update" no longer describe the
> > correct procedure to provide a driver update from a PXE server?
> > 
> 
> Here is my thought:
> I am not sure about the procedure here whether works, I use another way during
> my testing which works fine. It has been described in the link:
> http://intranet.corp.redhat.com/ic/intranet/AnacondaInitrdUpdate.html. 
> And also it's easy, not so many steps. Can we just change for that way? 

This looks reasonable to me, however, the procedure currently in the guide is the result of bug #508252 based on information provided there by msivak (CC'ing)

Therefore, I'll wait to hear from Jon or Martin before changing this procedure. 

Cheers
Rudi
Comment 24 Martin Sivák 2010-08-23 09:56:50 EDT
Guys I think we support loading NEW drivers from NFS/HTTP/...

We only can't UPDATE drivers this way. This was never tested by me though, because all driverdiscs I have are the update ones..
Comment 25 Jon Masters 2010-08-23 18:12:05 EDT
The vast majority of driver disks are of the "update" form, so we cannot have an install guide section that discusses the very rare case of a completely new driver. Instead, let's just cover the PXE/initramfs option for network installs. We can revisit this, possibly, in RHEL6.1 iff we get feedback from partners.
Comment 26 Ruediger Landmann 2010-08-23 18:27:46 EDT
Thanks Jon -- 

FWIW, the section covering HTTP/FTP/NFS driver "updates" did carry an "Important" admonition advising users that this procedure only worked for new drivers, not updates to existing drivers. If this mechanism still works (with the same limitations), is it worth reinstating the text (together with the admonition)?

With regard to the initramfs updates, do we need to keep the more complex procedure currently in the guide (from Bug #508252), or can we use the simpler procedure Chao describes in comment 22 here? 

(And if so, where does the initrd.img come from for the step "Extract the initrd.img to a folder"? Is this the initrd.img from the "images/pxeboot" directory on the installation DVD?)

Cheers
Rudi
Comment 27 Jon Masters 2010-08-23 22:47:35 EDT
I sent a reply to your email. Also, for the record here, I suggested:

1). We drop the network update option over HTTP/FTP/NFS. In accordance with comments elsewhere, we have decided not to officially support this, at least in 6.0, and therefore do not want the overhead of having people use it. If *we* need to do this ourselves for some reason, that is another matter entirely :)

2). The simpler approach is still implemented in the code (having the dd.iso image contained within the initramfs) so I really want to hear from Martin if this is now not possible (if it isn't, that ideally needs fixing for 6.1 so that anaconda just unpacks the iso image - makes things consistent). However, if in fact that code has rotted a little and Martin prefers the other approach, I am fine with that. Please check with him directly.

There shouldn't be a need to extract the initrd in either case, since the bootloader supports joining two together in overlay form. If the instructions suggest editing the one we ship, they are wrong. Which instructions exactly?

Jon.
Comment 28 Ruediger Landmann 2010-08-24 00:55:10 EDT
(In reply to comment #27)

Thanks so much for the quick turnaround Jon :)

I'm therefore leaving out HTTP/FTP/NFS.

> 2). The simpler approach is still implemented in the code (having the dd.iso
> image contained within the initramfs) so I really want to hear from Martin if
> this is now not possible (if it isn't, that ideally needs fixing for 6.1 so
> that anaconda just unpacks the iso image - makes things consistent). However,
> if in fact that code has rotted a little and Martin prefers the other approach,
> I am fine with that. Please check with him directly.
> 
> There shouldn't be a need to extract the initrd in either case, since the
> bootloader supports joining two together in overlay form. If the instructions
> suggest editing the one we ship, they are wrong. Which instructions exactly?

Chao's instructions in comment 22:

  Replace step 2 to step 7 in 6.2.3 with the following 2 steps: 
  ######################################################
  2. Extract the initrd.img to a folder, e.g /tmp/initrd_update/. 

  3. Copy the dd.iso file to the extracted initrd.img folder. 
  $ cp dd.iso /tmp/initrd_update/dd.img
  #######################################################

For comparison, the same technique is documented in the RHEL5 Installation Guide: http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/sect-Preparing_an_initial_RAM_disk_update-x86.html

If this method is indeed still supported and is going to stay supported, I can revert to that text. Martin, what do you think?

Cheers
Rudi
Comment 29 Martin Sivák 2010-08-24 05:22:56 EDT
This is still present in the code, so <initrd>/dd.img should be still supported.
Comment 30 Ruediger Landmann 2010-08-24 08:34:55 EDT
Thanks Martin; I've reinstated the procedure from the RHEL6 Installation Guide in Build 0-93

Note to QE:

This bug now covers 3 changes:

1. there should be no reference to a driver update disk on USB -- USB should only be mentioned in the context of holding an ISO image file of a driver disk

2. There should be no reference to loading a driver update from a HTTP, FTP, or NFS location

3. The procedure in "6.2.3  Preparing an initial RAM disk update" should match that described in "7.2.3  Preparing an initial RAM disk update" in the RHEL5 Installation Guide.
Comment 31 Jon Masters 2010-08-24 13:43:10 EDT
Thanks everyone.
Comment 32 Andrew Ross 2010-08-24 19:17:51 EDT
Verified: Red_Hat_Enterprise_Linux-Installation_Guide-6-web-en-US-0-93.el5

(In reply to comment #30)
> Thanks Martin; I've reinstated the procedure from the RHEL6 Installation Guide
> in Build 0-93
> 
> Note to QE:
> 
> This bug now covers 3 changes:
> 
> 1. there should be no reference to a driver update disk on USB -- USB should
> only be mentioned in the context of holding an ISO image file of a driver disk
> 

place the ISO image file of the driver disc in a location accessible to the installer:

   1. on a local hard drive
   2. a USB flash drive 

Methods that use the image file itself

        * local hard drive
        * USB flash drive 

> 2. There should be no reference to loading a driver update from a HTTP, FTP, or
> NFS location
> 

None found.

> 3. The procedure in "6.2.3  Preparing an initial RAM disk update" should match
> that described in "7.2.3  Preparing an initial RAM disk update" in the RHEL5
> Installation Guide.

Only difference is PXE holding a 5.3 server image as opposed to a 6.0 (as you would expect).
Comment 33 Jon Masters 2010-08-25 01:55:59 EDT
Ok, and we're done :)
Comment 34 releng-rhel@redhat.com 2010-11-11 10:30:11 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.