Bug 623550 - /etc/cron.hourly/mcelog.cron: read: No such device
/etc/cron.hourly/mcelog.cron: read: No such device
Status: CLOSED DUPLICATE of bug 595930
Product: Fedora
Classification: Fedora
Component: mcelog (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-12 02:13 EDT by Nicolas Mailhot
Modified: 2011-03-03 04:05 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-09 23:14:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-12 02:13:47 EDT
Description of problem:
/etc/cron.hourly/mcelog.cron:

read: No such device

Version-Release number of selected component (if applicable):
mcelog-0.9pre1-0.1.fc13.x86_64
kernel-2.6.35.1-5.rc1.fc14.x86_64


How reproducible:
Happens every once in a while
Comment 1 Jon Masters 2010-08-17 14:03:12 EDT
Thanks. We've seen a few of these, so it's probably a DUP and I'll fix that up later. Just taking the bug for now.
Comment 2 Paul Howarth 2010-10-28 09:21:33 EDT
Looks like a duplicate of kernel Bug #615530

Comments there suggest the message appears the first time the job runs after reboot.
Comment 3 Jon Masters 2010-11-09 23:14:59 EST

*** This bug has been marked as a duplicate of bug 595930 ***
Comment 4 Jon Masters 2010-11-10 04:04:26 EST
Ok. There are two bugs here. Some systems don't have an MCE device. Some do, and in either case you might have a /dev/mcelog device but the first read from it generally will fail after booting. I added a hack to the version of mcelog that I just built (which also reworks it to use systemd and run as a daemon) such that it will try twice - delaying between opens - as a horrible hack until Andi fixes whatever is broken in the kernel. I will ping him shortly as I have quite a list of things I had to fix in mcelog to make it work as a daemon that obviously had never been tested in the upstream version.

Note You need to log in before you can comment on or make changes to this bug.