Bug 623561 - prefdm.service should wait for livesys.service
Summary: prefdm.service should wait for livesys.service
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd   
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-12 06:51 UTC by Adam Williamson
Modified: 2010-08-19 01:09 UTC (History)
4 users (show)

Fixed In Version: systemd-7-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 01:09:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add the dependency to prefdm.service (415 bytes, patch)
2010-08-12 06:51 UTC, Adam Williamson
no flags Details | Diff
updated version of the patch (420 bytes, patch)
2010-08-12 08:15 UTC, Adam Williamson
no flags Details | Diff

Description Adam Williamson 2010-08-12 06:51:40 UTC
Created attachment 438357 [details]
patch to add the dependency to prefdm.service

When booting a Fedora live service, a livesys service can potentially make some changes to X configuration (it has special case X configs for some OLPC devices, and it should configure X to use a specific driver if you pass the parameter xdriver=foo - this doesn't currently work, but I'm submitting a patch for that to spin-kickstarts). However, in systemd, prefdm.service isn't configured to wait for livesys.service, so these X config changes aren't actually respected (at least in my test systems) because systemd manages to start X before livesys service gets to making the changes.

prefdm.service should be patched to have After = livesys.service . Patch attached.

(Testing this is a bit tricky because you need a non-Intel, non-Nvidia system to be sure, and it seems like kvm vms currently hang if you try to use the vesa driver. So for now, my 'test' for this is to boot a live image with the fixes to systemd and spin-kickstarts, and pass parameters 'xdriver=vesa nomodeset'. If the live image gets to a graphical desktop using the cirrus driver it's broken, and if the live image completely freezes on X start, it's working!)

Comment 1 Adam Williamson 2010-08-12 06:51:53 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2010-08-12 08:14:28 UTC
correction: it should wait for livesys-late.service , not just livesys.service . updated patch attached. this does 'the right thing' in my hang test...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2010-08-12 08:15:24 UTC
Created attachment 438364 [details]
updated version of the patch

Comment 4 Fedora Update System 2010-08-12 15:29:51 UTC
systemd-7-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/systemd-7-3.fc14

Comment 5 Bill Nottingham 2010-08-12 16:26:53 UTC
Given when prefdm historically starts, shouldn't it just be after local.service instead?

Comment 6 Adam Williamson 2010-08-12 16:40:29 UTC
bill: I think it's more correct to think of the relationships as being 'dependencies', since systemd is intended not to be sequential at all. we can't necessarily assume that local.service is being started after livesys-late.service unless they have that relationship expressed between them...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Bill Nottingham 2010-08-12 16:50:59 UTC
We sort of can, due to the fact that it sets SysVStartPriority. Of course, it's possibly better defined as a target, since it by definition needs to be After: everything-else.

Comment 8 Fedora Update System 2010-08-12 19:48:18 UTC
systemd-7-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update systemd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/systemd-7-3.fc14

Comment 9 Lennart Poettering 2010-08-14 18:02:56 UTC
I generally believe that we should keep the amount of synchronization and dependencies at a minimum. That means that I'd rather not add an ordering dep between local.service in prefdm.service

Comment 10 Fedora Update System 2010-08-19 01:09:18 UTC
systemd-7-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.