Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623589 - consumergroup: creation lists a description [ ] as empty, w/ no option to specify a description
consumergroup: creation lists a description [ ] as empty, w/ no option to spe...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Retired
Component: z_other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sayli Karmarkar
wes hayutin
: QA-Closed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 04:55 EDT by wes hayutin
Modified: 2015-03-22 21:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-20 12:11:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2010-08-12 04:55:28 EDT
[root@localhost tmp]# pulp -u test01 -p dog8code consumergroup create --id=consumergroup-test01
Creating empty consumer group
 Successfully created Consumer group [ consumergroup-test01 ] with description [  ]
[root@localhost tmp]# 


** notice; description is empty

from the consumergroup --help


Options:
  -h, --help            show this help message and exit
  --consumerid=CONSUMERID
                        Consumer Identifier
  --id=GROUPID          Consumer Group Identifier
  -u USERNAME, --username=USERNAME
                        <REQUIRED> username for access to Pulp.  Default user
                        admin is included with base install.
  -p PASSWORD, --password=PASSWORD
                        <REQUIRED> password for access to Pulp.
Comment 1 wes hayutin 2010-08-12 05:02:40 EDT
commit bf585b29f96375917499d850d93859e00088c4fd
Comment 2 Sayli Karmarkar 2010-08-12 12:37:55 EDT
I can see correct options: 

$ sudo pulp consumergroup create --help
Usage: pulp -u <username> -p <password> consumergroup create [OPTIONS]


Options:
  -h, --help            show this help message and exit
  --id=ID               consumer group id
  --description=DESCRIPTION
                        description of consumer group
  --consumerids=CONSUMERIDS
                        consumer id list to be included in this group
  -u USERNAME, --username=USERNAME
                        <REQUIRED> username for access to Pulp.  Default user
                        admin is included with base install.
  -p PASSWORD, --password=PASSWORD
                        <REQUIRED> password for access to Pulp.

I don't think help in the bug report was consumergroup create help, because it should not have --consumerid=CONSUMERID as an option.
Comment 3 wes hayutin 2010-08-12 13:39:07 EDT
indeed


[root@localhost pulp]# pulp -u test01 -p dog8code consumergroup create --help
Usage: pulp -u <username> -p <password> consumergroup create [OPTIONS]


Options:
  -h, --help            show this help message and exit
  --id=ID               consumer group id
  --description=DESCRIPTION
                        description of consumer group
  --consumerids=CONSUMERIDS
                        consumer id list to be included in this group
  -u USERNAME, --username=USERNAME
                        <REQUIRED> username for access to Pulp.  Default user
                        admin is included with base install.
  -p PASSWORD, --password=PASSWORD
                        <REQUIRED> password for access to Pulp.
[root@localhost pulp]#
Comment 4 Preethi Thomas 2010-10-20 12:11:25 EDT
Closed after review.

Note You need to log in before you can comment on or make changes to this bug.