Bug 623594 - [RFE] backport xmlrpc with keepalive to python 2.6
Summary: [RFE] backport xmlrpc with keepalive to python 2.6
Status: CLOSED DUPLICATE of bug 630756
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Dave Malcolm
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 565939
TreeView+ depends on / blocked
 
Reported: 2010-08-12 09:05 UTC by Dan Kenigsberg
Modified: 2011-03-03 22:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-28 02:31:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Kenigsberg 2010-08-12 09:05:40 UTC
Description of problem:
python 2.6's xmlrpc implementation does not make use of HTTP/1.1's keepalive: it forces client and server to renegotiate a connection for every function call. This is particularly expensive when working over HTTPS.

A solution for this has been submitted to python 2.7, see http://bugs.python.org/issue6267 . Would you backport it to RHEL6?

Version-Release number of selected component (if applicable):
python-2.6.5-3.el6.x86_64

Comment 1 Dave Malcolm 2010-08-12 14:17:02 UTC
Looks like r73638 is the trunk fix, but it introduced regressions and we'd also need r73821 and r73822, at least.

Comment 3 Dave Malcolm 2011-01-28 02:31:17 UTC

*** This bug has been marked as a duplicate of bug 630756 ***


Note You need to log in before you can comment on or make changes to this bug.