Bug 623607 - RPMlint doesn't recognize Python 2.7 generated byte-compiles files
RPMlint doesn't recognize Python 2.7 generated byte-compiles files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: Python27
  Show dependency treegraph
 
Reported: 2010-08-12 05:59 EDT by Nils Philippsen
Modified: 2010-08-24 04:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.99-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 04:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch which adds the magic value for Python 2.7 byte-compiled files (371 bytes, patch)
2010-08-12 05:59 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2010-08-12 05:59:47 EDT
Created attachment 438388 [details]
Patch which adds the magic value for Python 2.7 byte-compiled files

Description of problem:
FilesCheck.py in rpmlint lacks the magic value for byte-compiled python files generated by Python 2.7.

Version-Release number of selected component (if applicable):
rpmlint-0.98-1.fc14.noarch
Comment 1 Ville Skyttä 2010-08-19 04:42:32 EDT
Applied upstream, thanks, new release will follow soon.
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1800
Comment 2 Fedora Update System 2010-08-19 12:34:02 EDT
rpmlint-0.99-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/rpmlint-0.99-1.fc14
Comment 3 Fedora Update System 2010-08-23 21:33:09 EDT
rpmlint-0.99-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.