Bug 623613 - scripting providers do not work
scripting providers do not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 06:18 EDT by David Tardon
Modified: 2010-09-13 15:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 15:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tardon 2010-08-12 06:18:36 EDT
Description of problem:
We distribute script providers for JavaScript, BeanShell and Python as bundled extensions (since 3.3). Unfortunately, according to http://wiki.services.openoffice.org/wiki/Documentation/DevGuide/Extensions/Packaging_Notes, this only works for oxt-style extensions, i.e. the extension directory must contain manifest and description.xml, otherwise it's ignored. This means it's currently not possible to manage/use macros written in one of these languages.

Version-Release number of selected component (if applicable):
openoffice.org-3.3.0-3.3.0-2.3.fc14.1

How reproducible:
always

Steps to Reproduce:
1. yum install openoffice.org-rhino
2. unopkg list --bundled
3. look for ScriptProviderForJavaScript in the output
Comment 1 David Tardon 2010-08-12 08:58:06 EDT
fix committed, will be in >= 3.3.0-3.5.fc14
Comment 2 Caolan McNamara 2010-08-12 09:15:53 EDT
caolanm->dtardon: Do you want to take on the task of doing the right thing of changing vanilla upstream to get it to also build the script providers as bundled .oxts by default, which is something I had intended to do, but it fell off the radar, which was a poor decision in retrospect.
Comment 3 David Tardon 2010-08-12 09:41:49 EDT
dtardon->caolanm: I'll look at it. Anything that will result in simplifying our spec is surely worth doing...
Comment 4 Fedora Update System 2010-08-12 14:51:35 EDT
openoffice.org-3.3.0-4.1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-4.1.fc14
Comment 5 Fedora Update System 2010-08-17 04:25:27 EDT
openoffice.org-3.3.0-4.3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-4.3.fc14
Comment 6 Fedora Update System 2010-08-23 21:24:44 EDT
openoffice.org-3.3.0-4.3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Caolan McNamara 2010-09-13 15:52:40 EDT
all good in 3.3.0-6.2.fc14

Note You need to log in before you can comment on or make changes to this bug.