Bug 623640 - pklogin_finder and pkcs11_inspect both pass command name to pk_configure
pklogin_finder and pkcs11_inspect both pass command name to pk_configure
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam_pkcs11 (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bob Relyea
Chandrasekar Kannan
https://www.opensc-project.org/pam_pk...
:
Depends On:
Blocks: 786154
  Show dependency treegraph
 
Reported: 2010-08-12 07:47 EDT by Martin Poole
Modified: 2015-01-04 18:43 EST (History)
11 users (show)

See Also:
Fixed In Version: pam_pkcs11-0.5.3-26.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 586422
Environment:
Last Closed: 2012-02-21 00:59:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0215 normal SHIPPED_LIVE pam_pkcs11 bug fix update 2012-02-20 09:53:18 EST

  None (edit)
Comment 4 Bob Relyea 2011-03-25 18:09:15 EDT
pam_pkcs11 does not appear to be approved for RHEL5.7. If you can get approval for this component, and all the approvals by Wednesday (I have to have all my stuff in by Thursday, including builds and errata). Otherwise I'll dev+ it for 5.8.

bob
Comment 9 Bob Relyea 2011-06-22 15:10:17 EDT
dev_ack as promised in comment 4.
Comment 11 Asha Akkiangady 2012-01-11 13:50:13 EST
Verified on a RHEL 5.8 client with pam_pkcs11-0.5.3-25.el5.
Executed pklogin_finder and pkcs11_inspect commands, smart card is recognized successfully and maps to the user,  /var/log/messages does not show entries like "pklogin_finder: argument /usr/bin/pklogin_finder is not supported by this module" or "pkcs11_inspect: argument /usr/bin/pkcs11_inspect is not supported by this module".

Marking the bug verified.
Comment 12 Ray Strode [halfline] 2012-01-13 16:19:35 EST
Note this fix is a bit too simple and repeats a mistake upstream made in the rhel6 development timeframe.  See 

https://www.opensc-project.org/pam_pkcs11/ticket/29

for what we did for rhel6.
Comment 13 Asha Akkiangady 2012-01-13 16:23:44 EST
Re-opened this bug as it breaks pam_pkcs11.so argument handling.
Comment 16 Bob Relyea 2012-01-18 17:31:57 EST
I have patch ready to go once the blocker is set to "+"
Comment 17 Bob Relyea 2012-01-20 12:53:10 EST
New build complete
Comment 19 Asha Akkiangady 2012-01-24 11:07:07 EST
Smart card login is successful in graphical and virtual terminal with pam_pkcs11-0.5.3-26.el5. 


Marking the bug verified.
Comment 20 errata-xmlrpc 2012-02-21 00:59:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0215.html

Note You need to log in before you can comment on or make changes to this bug.