Bug 62365 - Gnome-core should not require sawfish, only a window manager
Summary: Gnome-core should not require sawfish, only a window manager
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-core (Show other bugs)
(Show other bugs)
Version: skipjack-beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-30 11:22 UTC by W. Michael Petullo
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-30 11:22:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2002-03-30 11:22:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
Gnome-core should not require sawfish, as GNOME will work fine with other window
managers.  Instead, gnome-core should require a meta-package, window manager,
which could be provided by sawfish, enlightenment, fvwm2, etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  rpm -q --requires gnome-core
2.  Notice that sawfish is listed

Additional info:

Comment 1 Havoc Pennington 2002-03-31 20:26:15 UTC
The Requires: is needed so that people upgrading from previous versions that
used Enlightenment instead will be given the option to migrate to Sawfish by
default. Other WMs work with GNOME but they are unsupported.

The only issue here is saving some disk space, that isn't as important as
pulling in Sawfish on upgrades.


Note You need to log in before you can comment on or make changes to this bug.