Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 623667 - seeker hits random bytes unaligened
seeker hits random bytes unaligened
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: seeker (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 09:27 EDT by Ege Turgay
Modified: 2010-08-19 07:24 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 07:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patched code (4.91 KB, text/plain)
2010-08-12 09:27 EDT, Ege Turgay
no flags Details

  None (edit)
Description Ege Turgay 2010-08-12 09:27:58 EDT
Created attachment 438437 [details]
the patched code

Description of problem:
i've been told that it wasn't testing the i/o accurately because it was choosing its starting location as a random number of bytes into the disk, then the most of the time you will need to read two sectors to get 512 bytes.
only if you choose a starting byte divisible by 512 will you read your whole 512 bytes from a single sector. Using direct i/o with memory and buffer alignment fixes this issue as well. One of my colleagues (Mr. Ian Sherratt) patched this, so i don't have a good understanding of the code. I've attached the patched version

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. just running the test
2.
3.
  
Actual results:
n/a

Expected results:
n/a

Additional info:
Comment 1 Ville Skyttä 2010-08-19 07:24:01 EDT
http://pkgs.fedoraproject.org/gitweb/?p=seeker.git;a=commitdiff;h=fe5760ae0e426449aeb7d5357b30a0f9b3749a5d

Thanks, modified patch applied in devel and built for Rawhide, let's see if someone spots a problem with it.

Note You need to log in before you can comment on or make changes to this bug.