Bug 62368 - browser hangs
Summary: browser hangs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: elinks
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61901 67218 79579
TreeView+ depends on / blocked
 
Reported: 2002-03-30 16:36 UTC by Chris Ricker
Modified: 2008-05-01 15:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-01-10 13:30:31 UTC


Attachments (Terms of Use)

Description Chris Ricker 2002-03-30 16:36:43 UTC
This is a highly reproducible hang.

Go to http://sunsolve.sun.com/

Under the middle column labeled "Security Information," select "Security
T-patches" (note:  registration will not be required for this)

At the bottom of the T-patches screen, select the IMG on the left (agreeing to
the T-patches preliminary warning license).

On the next page which pops up (patch license agreement), there seems to be no
way to navigate past the license dialog.  Moving down the page with the down
arrow puts the cursor in the text box with the license, and once in that box,
there is no way to get out that I can find.  The cursor eventually just hangs,
refusing to allow any movements.

lynx does not have this problem.

Comment 1 Bernhard Rosenkraenzer 2002-04-02 12:20:49 UTC
There is a way to navigate past it - Page-Down to the bottom, then press 
up-arrow until you are where you want to be. 


Comment 2 Chris Ricker 2002-04-06 19:55:13 UTC
Okay, that works.  I also noticed that if you get it "hung" by just moving with
the down arrow, the PgDn key will unhang it.  That's still kinda ugly, but not
as bad as it being permanently hung.

Comment 3 Tim Waugh 2002-12-23 11:50:50 UTC
Fixed package is elinks-0.3.2-3, which will shortly appear in rawhide.  Please
verify that it fixes the problem for you.  Thanks.

Comment 4 Chris Ricker 2002-12-23 15:59:27 UTC
closing rawhide - elinks-0.3.2-2 from phoebe doesn't have this problem

Thanks!

Comment 5 Tim Waugh 2002-12-23 16:54:36 UTC
Please re-test with elinks-0.3.2-3; I could reproduce the problem with 0.3.2-2,
and have made a code change.

I expect it will appear in rawhide in the next couple of days.

Comment 6 Chris Ricker 2002-12-23 17:20:00 UTC
Oops, you're right. When I tested 0.3.2-2 before, I followed the wrong img icon
;-(. It does hang for me too -- sorry about that.

I'll test 0.3.2-3 and see what happens

Comment 7 Tim Waugh 2003-01-08 13:28:54 UTC
*ping*

Comment 8 Jay Turner 2003-01-10 13:30:31 UTC
Fix confirmed with elinks-0.3.2-3.


Note You need to log in before you can comment on or make changes to this bug.