Bug 623682 - errata workflow doesn't work properly in beaker (and rhts)
errata workflow doesn't work properly in beaker (and rhts)
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.5
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: Bill Peck
Karel Srot
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 10:14 EDT by Karel Srot
Modified: 2011-03-24 09:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-24 09:15:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2010-08-12 10:14:55 EDT
Description of problem:

Hi, back again with errata workflow problems. I have executed few workflows and none of them passed, .e.g
https://beaker.engineering.redhat.com/jobs/11854

The main problem is the failure during 
/distribution/comparative/prepare-rhtslib 
(downgrade fails which means that "old" packages to be tested in errata workflow are not present)

Later on also 
/distribution/comparative/upgrade-rhtslib
fails. Maybe the failure during a downgrade phase is the reason, I didn't have a change to verify it yet.

The same applies for RHTS
http://rhts.redhat.com/cgi-bin/rhts/recipes.cgi?id=436070
therefore it seems to be a problem in both tests. Unfortunately I do not know where to file a bug againts them. Feel free to reassing it to a right component. 


How reproducible:
clone https://beaker.engineering.redhat.com/jobs/11854
Comment 1 Marian Csontos 2010-08-23 08:47:34 EDT
If it does not work in RHTS it is not a blocker: beaker-blocker is be definition only something  preventing us from switching rhts off.
Comment 2 Karel Srot 2010-08-23 09:39:10 EDT
Well, this is funny. The problem is that pmuller might have a motivation to fix those things when there was only RHTS but as he already said he is not interrested in supporting this "hack" in Beaker. You can remove the blocker but I am afraid that the only result will be the Beaker without a chance to test errata packages.
Comment 3 Michal Nowak 2010-10-08 04:10:26 EDT
Testing z-stream erratum is so painful today. Really reminds me 2007 errata testing on Stable Systems.
Comment 4 Bill Peck 2011-03-23 17:47:54 EDT
Is this working with workflow-tcms?
Comment 5 Karel Srot 2011-03-24 04:57:23 EDT
AFAIK workflow-tcms is working fine. Unfortunately, I can't test it on this particular errata since it has been already released.
I think we can close this bug.
Comment 6 Bill Peck 2011-03-24 09:15:13 EDT
closing.  any new errata issues should be reported against workflow-tcms

Thanks

Note You need to log in before you can comment on or make changes to this bug.