Bug 623707 - RFE use squashfs directly instead of ext3 inside of squashfs
Summary: RFE use squashfs directly instead of ext3 inside of squashfs
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bruno Wolff III
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-12 15:12 UTC by Bruno Wolff III
Modified: 2011-08-31 03:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 23:04:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2010-08-12 15:12:01 UTC
Description of problem:
Now (kernel 2.6.35, squashfs-tools 4.1) that squashfs supports xattr it may be possible to use squashfs for / directly instead of using ext3 inside of squashfs. (xattr support is needed for selinux support.) This should speed up both creation and use. It's possible that there are some other gotchas.

Comment 1 Fedora Admin XMLRPC Client 2010-10-21 17:53:21 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Bruno Wolff III 2011-02-05 16:10:53 UTC
Note that this is going to impact installs from the live image as we will need to run unsquashfs instead of dd and we will not be able to use the resize trick. This will have performance implications. Also there is discussion about using a single way to install for both anaconda and liveinst they may impact this.

Comment 3 Brian Lane 2011-08-08 23:04:21 UTC
During an unrelated chat with wwoods today he mentioned that the extX inside squashfs is needed because we want to be able to do a writable overlay which you can't do with just a squashfs. So I don't think this will happen until squashfs has write support.


Note You need to log in before you can comment on or make changes to this bug.