Bug 62374 - paragraph formatting broken
paragraph formatting broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: wdovlrrw
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-30 14:04 EST by Chris Ricker
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-10 13:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example paragraphs (2.35 KB, text/plain)
2002-03-30 14:07 EST, Chris Ricker
no flags Details
example paragraphs after beta vim malformatted them (2.37 KB, text/plain)
2002-03-30 14:08 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2002-03-30 14:04:01 EST
the vim 6.1-1 rpms are installed

Paragraph formatting (meaning the command "gq}" to reformat an entire paragraph)
is behaving very weirdly with the vim in the betas.  Sometimes, reformatting an
entire paragraph will result in lines towards the end of the paragraph being
indented.

What it appears to be breaking on are lines ending with a comma.  When a
reformat shifts a line so that the physical line ends with a comma, all
subsequent lines in that paragraph are indented.

This is not how paragraph format has worked on any other vi / vim I've used, and
it's not what happens with the exact same paragraphs on 7.2.
Comment 1 Chris Ricker 2002-03-30 14:07:51 EST
Created attachment 51465 [details]
example paragraphs
Comment 2 Chris Ricker 2002-03-30 14:08:50 EST
Created attachment 51466 [details]
example paragraphs after beta vim malformatted them
Comment 3 Chris Ricker 2002-03-30 14:12:54 EST
I've attached two files, foo.txt and foo-beta.txt.  They both contain the same
three paragraphs (all alphabetical characters substituted with an "a" since the
text is unfortunately confidential).  foo.txt is what the file looks like before
and after "gq}" processing using vim on a RH 7.2 box.  foo-beta.txt is what
foo.txt looks like after "gq}" processing using vim-6.1-1 on beta3.

This bug did not arise with 6.1-1; I've been noticing it for a few days now.  It
does seem to be exclusively associated w/ lines ending in commas.
Comment 4 Chris Ricker 2002-04-05 01:37:18 EST
still broken in beta4
Comment 5 Chris Ricker 2002-05-05 11:46:24 EDT
Still broken in 7.3 gold
Comment 6 Karsten Hopp 2002-07-09 05:54:36 EDT
It's fixed in the rawhide version.

Note You need to log in before you can comment on or make changes to this bug.