Bug 623781 - per-channel 'beep on message' flags not being respected
Summary: per-channel 'beep on message' flags not being respected
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-12 18:47 UTC by Frank Ch. Eigler
Modified: 2010-11-30 16:03 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-30 16:03:36 UTC


Attachments (Terms of Use)

Description Frank Ch. Eigler 2010-08-12 18:47:27 UTC
Description of problem:
While the xchat channel-tab gui appears to offer per-channel settings
for 'beep on message', xchat does not seem to respect the flag properly.
It is desirable to let some channels beep and others not, but alas...

Version-Release number of selected component (if applicable):
xchat-2.8.8-2.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. make a new channel tab with /join #foobar on some server
2. unselect its 'beep on messages' option
3. join same channel from another client
4. observe beeps anyway

It may be necessary to have some other tab with the beep-on-message flag
on to see this phenomenon.

Comment 1 Frank Ch. Eigler 2010-11-30 16:03:36 UTC
Sorry, on further experimentation, I found that my session-wide
'beep on message' flag in the preferences was also set, overriding
the per-channel flags.  It might be nice to grey out the per-channel
menu item, if it's being overridden, but that's a small thing.


Note You need to log in before you can comment on or make changes to this bug.