Bug 62379 - openssl compiled for i686
openssl compiled for i686
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: openssl (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-30 15:51 EST by Matthew Galgoci
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 16:38:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Galgoci 2002-03-30 15:51:20 EST
Description of Problem:

openssl is compiled with i686 specific instructions and won't run on any of
my older hardware (various i586 chips). An illegal instruction exception is 
generated.

Version-Release number of selected component (if applicable):

Tried current beta and current rawhide.

How Reproducible:

Try and run openssl on a non 686 machine and it should happen every
time.

Additional Information:

I recompiled openssl with the following flags and it works now:

sslarch=linux-elf
sslflags="no-asm 386"
Comment 1 Bill Nottingham 2002-04-01 16:16:21 EST
Did you install the i386 or i686 package?
Comment 2 Matthew Galgoci 2002-04-01 16:38:14 EST
doah.

I didn't realize that openssl had been broken out into i386 and i686 packages.

The machine was installed on an i686 and I rolled back the kernel and libc by 
hand before dropping the drive into the i586 machine.

I AssuMed there was only one openssl package.

Let me double check on this tonight before closing this bug as NOTABUG (or 
rather PEBKAC)
Comment 3 Matthew Galgoci 2002-04-01 16:38:32 EST
doah again.
Comment 4 Matthew Galgoci 2002-04-08 01:22:47 EDT
Ok, verified that this is NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.