Bug 623804 - abrt not working at all
abrt not working at all
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Toman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 15:48 EDT by Rob
Modified: 2015-03-22 20:41 EDT (History)
9 users (show)

See Also:
Fixed In Version: abrt-1.1.13-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 04:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dbus-abrt.conf (762 bytes, application/octet-stream)
2010-08-17 07:12 EDT, Rob
no flags Details

  None (edit)
Description Rob 2010-08-12 15:48:11 EDT
Doing either:
"abrt-gui" from terminal
Wait for a package to crash and attempting to view the problem via the icon in the top right corner

Leads to this message:

Error while loading the dumplist.
org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

I reinstalled abrt, and now starting abrt i get this:

Error while loading the dumplist.
abrt daemon is not running, and DBus can't start it

I also get Selinux denial events right after trying to start abrt-gui, at the same time, which are attachments

Running the /sbin/restorecon '/var/run/abrt.pid' as suggested by SELinux, runs successfully but now when starting abrt-gui i get the original error message:

Error while loading the dumplist.
org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
Comment 1 Michal Toman 2010-08-16 08:47:03 EDT
Could you be more specific when describing how to reproduce? What version of ABRT are you using? What is the package whose crash leads to the error?
Comment 2 Rob 2010-08-16 13:32:44 EDT
abrt version: abrt.x86_64   1.1.1-2.fc13

Well i get the dbus error when ever i try to start abrt so either running "abrt-gui" from terminal or going applications->system tools-> Automatic bug reporting tool

Also occurs when ever any other program crashes (appears to be any package, though very few of my packages ever crash so i cant tell if its one in particular) and i click the flashing icon in the top corner.
Comment 3 Michal Toman 2010-08-17 04:44:04 EDT
I'm still not able to reproduce. It seems to be some wrong configuration in security policy. I guess you don't get SELinux denial with the org.freedesktop.DBus.Error.NoReply error, right? Can you attach your
/etc/dbus-1/system.d/dbus-abrt.conf file?
Comment 4 Jiri Moskovcak 2010-08-17 05:47:37 EDT
And can you please try to update to the latest abrt version?

$ yum update abrt --enablerepo=updates-testing

should be abrt-1.1.13-2.

Thank you,
Jirka
Comment 5 Rob 2010-08-17 07:12:32 EDT
The selinx denial was only after i tried reinstalling abrt

Heres the dbus added as attachment

Updating seems to of fixed the problem no more dbus errors when trying to start abrt, though havn't tested it for when a package does crash. Is there anyway to force a package to crash such that abrt catches it?
Comment 6 Rob 2010-08-17 07:12:59 EDT
Created attachment 439090 [details]
dbus-abrt.conf
Comment 7 Michal Toman 2010-08-17 07:28:05 EDT
You can emulate crash by sending SIGABRT to process:

$ xterm &
[1] 9323
$ kill -6 9323
Comment 8 Rob 2010-08-17 12:03:09 EDT
Everything seems to be working fine now, Thanks!

Note You need to log in before you can comment on or make changes to this bug.