Bug 623853 - libguestfs uses PyCObject API (deprecated in Python 2.7)
libguestfs uses PyCObject API (deprecated in Python 2.7)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PyCObject
  Show dependency treegraph
 
Reported: 2010-08-12 20:48 EDT by Dave Malcolm
Modified: 2010-08-27 03:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 03:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-08-12 20:48:15 EDT
Description of problem:
Python 2.7 deprecated the PyCObject API in favor of a new "capsule" API.
  http://docs.python.org/dev/whatsnew/2.7.html#capsules

The deprecations are set to "ignore" by default, so in theory the API still works.

However the deprecation has caused at least one app to fail (virt-manager, see bug 620216, due to it modifying the warning settings), so I've been doublechecking the scope of usage of the PyCObject, and am filing bugs against components that are possibly affected.

You can trigger a hard failure of the API via:
>>> import warnings
>>> warnings.filterwarnings('error')
and then use the affected part of the module (appears to be in py_guestfs_create).

./src/generator.ml:9507:    PyCObject_FromVoidPtrAndDesc ((void *) g, (char *) \"guestfs_h\", NULL);
./python/guestfs-py.c:56:    PyCObject_FromVoidPtrAndDesc ((void *) g, (char *) "guestfs_h", NULL);

I'm not yet sure what the best approach is to fixing this.

Version-Release number of selected component (if applicable):
python-libguestfs-1.5.2-4.fc14.x86_64

Note You need to log in before you can comment on or make changes to this bug.