Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623862 - RFE: pki-ra should not require sendmail, but MTA
RFE: pki-ra should not require sendmail, but MTA
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pki-ra (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Harmsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 21:15 EDT by S.A. Hartsuiker
Modified: 2011-06-28 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 10:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description S.A. Hartsuiker 2010-08-12 21:15:26 EDT
Description of problem:
the pki-ra rpm depends on package sendmail instead of the capability MTA or the *file* /usr/sbin/sendmail, which is actually a link provided by several packages.

Version-Release number of selected component (if applicable):
pki-ra-1.3.1-1.fc13.noarch

How reproducible:
Install pki-ra rpm and rpm -q --requires pki-ra

Steps to Reproduce:
1. yum install pki-ra
2. rpm -q --requires pki-ra 
3.
  
Actual results:
# rpm -q --requires pki-ra-1.3.1-1.fc13.noarch | grep -iE "mail|mta|smtp"
sendmail  


Expected results:
# rpm -q --requires pki-ra-1.3.1-1.fc13.noarch | grep -iE "mail|mta|smtp"
/usr/sbin/sendmail  

or

# rpm -q --requires pki-ra-1.3.1-1.fc13.noarch | grep -iE "mail|mta|smtp"
MTA  

Additional info:
Comment 2 Matthew Harmsen 2010-12-14 17:38:38 EST
TIP:

# cd pki

# svn diff
Index: ra/pki-ra.spec
===================================================================
--- ra/pki-ra.spec	(revision 1624)
+++ ra/pki-ra.spec	(working copy)
@@ -21,7 +21,7 @@
 Requires:       pki-selinux
 Requires:       pki-setup
 Requires:       perl-DBD-SQLite
-Requires:       sendmail
+Requires:       /usr/sbin/sendmail
 Requires:       sqlite
 Requires(post):    chkconfig
 Requires(preun):   chkconfig

# svn status | grep -v ^$ | grep -v ^P | grep -v ^X | grep -v ^?
M       ra/pki-ra.spec

# svn commit
Sending        dogtag/ra/pki-ra.spec
Transmitting file data .
Committed revision 1625.
Comment 3 Matthew Harmsen 2010-12-14 17:40:21 EST
NOTE:  This bug was also fixed in the new CMAKE build system on the TIP as a part
       of the check-ins related to "Bugzilla Bug #586073 - Add new 
       'mod_revocator' runtime dependency to RA and TPS . . ."
Comment 4 Bug Zapper 2011-06-01 07:32:40 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2011-06-28 10:38:40 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.