Bug 62389 - performance analysis for printing a lot of glyphs
performance analysis for printing a lot of glyphs
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-print (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-30 19:43 EST by Akira TAGOH
Modified: 2015-01-07 18:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 05:29:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix patch is here (13.86 KB, patch)
2002-03-30 19:44 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2002-03-30 19:43:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
I tried printing of the following file:
http://junk.brisbane.redhat.com/gb18030/double3.txt

that file was needed about 3 hours for outputting PS on my machine. it's
unbelievable! and PS file which is actually output can't be shown with gs
because gnome-print has a bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get double3.txt
2.run gedit with LANG=zh_CN.gb18030
3.read it and printing
	

Actual Results:  for printing, it needs a lot times.

Expected Results:  gb18030's font is too big. so I think that about 2 or 3
minutes would be better.

Additional info:
Comment 1 Akira TAGOH 2002-03-30 19:44:29 EST
Created attachment 51484 [details]
fix patch is here
Comment 2 Akira TAGOH 2002-03-30 19:54:48 EST
the above patch saved a lot of times. actually it finished printing that file in
about 2 or 3 minutes on my machine. it's reasonable, I think. it also contains
gnome-print's bug fix.

-
if (dx == 0 && dy == 0) return NULL;
+
if (dx == 0 && dy == 0) retval = g_strdup ("");

this code should not return NULL. (null) was output by this into PS file. I will
file this bug and patch to bugzilla.gnome.org too.
Comment 3 Havoc Pennington 2002-03-31 15:36:59 EST
Tagoh you're our gnome-print expert so I'll trust your patch is correct.

Can you rebuild gnome-print? I'm going to be gone this week for guadec.
Comment 4 Akira TAGOH 2002-04-01 05:49:16 EST
ok, I have built gnome-print with this patch. this problem will be fixed in
0.35-4. Thanks.
Comment 5 Akira TAGOH 2003-01-20 02:38:16 EST
the improvement of printing performance patch was missed in 0.37 - that patch
has been merged in 1.x series though. so we have this problem again in recent beta.
I submitted a patch again to the upstream bugzilla. see
http://bugzilla.gnome.org/show_bug.cgi?id=77182.
Comment 6 Akira TAGOH 2003-01-28 19:55:26 EST
the upstream marked it as WONTFIX, because they don't plan to release the 0.x
series anymore. but it's apparently affected our products.
This patch was applied to our old release, and it has been merged to the GNOME
2.x releases. so can you apply it to our gnome-print?
Comment 7 Owen Taylor 2003-02-06 12:00:38 EST
I'm going to be away for the next few days, but if you (or someone
else) want to apply the patch to our gnome-print RPM, I'm OK with
that.

[ Irrelevant comment -- I think the code would be a whole lot clearer
  and also more efficient if was using a GString as a buffer.
 
  I'm *not* suggesting you change this for our RPM. ]
Comment 8 Akira TAGOH 2003-02-07 05:29:51 EST
I don't have enough time to improve it until last public beta.
original patch was applied. this problem should be fixed in 0.37-4.
Comment 9 Owen Taylor 2003-02-08 06:48:33 EST
The original patch is fine, thanks.

Note You need to log in before you can comment on or make changes to this bug.