Bug 62396 - glibc-debug-2.2.5-27 crashes "ls -l"
glibc-debug-2.2.5-27 crashes "ls -l"
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
Blocks: 61590
  Show dependency treegraph
Reported: 2002-03-30 22:40 EST by greg hosler
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-06 02:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
valgrind output showing where the crash is (1.18 KB, text/plain)
2002-03-30 22:41 EST, greg hosler
no flags Details

  None (edit)
Description greg hosler 2002-03-30 22:40:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
installing glibc-debug, and trying to run a program, results in segment
violation. some programs run, some easily crash, reproduceably.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install glibc-debug-2.2.5-27
2. export LD_LIBRARY_PATH=/usr/lib/debug
3. ls -l will crash:


Actual Results:  ls -l crashed

Expected Results:  ls -l shouldn't crash

Additional info:

1) not knowing whether to or not, I tried adding /usr/lib/debug to
/etc/ld.so.conf, and reran ldconfig, but teh results are unchanged.
ls -l still crashes. note that a simple "ls" will work.

2) I ran valgrind to see where it is crashing. It appears that the
problem is in dl-open.c - see attachment
Comment 1 greg hosler 2002-03-30 22:41:24 EST
Created attachment 51504 [details]
valgrind output showing where the crash is
Comment 2 Jakub Jelinek 2002-04-05 03:51:57 EST
Cannot reproduce this with glibc-debug-2.2.5-28 (the one I have installed on
my box). Do you still have problems with current glibc (2.2.5-30)?
Comment 3 greg hosler 2002-04-06 02:02:55 EST
problem fixed in glibc-debug-2.2.5-30

Note You need to log in before you can comment on or make changes to this bug.