Bug 623961 - The installed system is not configured with boot command: xdriver=vesa after installing with basic video driver
The installed system is not configured with boot command: xdriver=vesa after ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 05:46 EDT by He Rui
Modified: 2010-08-17 04:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 04:33:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tmp logs during install (28.37 KB, application/x-gzip)
2010-08-15 23:20 EDT, He Rui
no flags Details
logs after reboot to desktop (54.92 KB, application/x-gzip)
2010-08-15 23:21 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2010-08-13 05:46:46 EDT
Description of problem:
Install F14-Alpha-RC4 with the 2nd option:'install with basic video driver', complete installation, and reboot. Check grub.conf or /proc/cmdline, xdriver=vesa is not added as boot command.

Version-Release number of selected component (if applicable):
F14-Alpha-RC4
xorg-x11-drv-vesa-2.3.0-1.fc14

How reproducible:
100%

Steps to Reproduce:
1. Install F14-Alpha-RC4 with the 2nd option:'install with basic video driver'
2. Reboot
3. Check grub.conf or /proc/cmdline
  
Actual results:
xdriver=vesa is not added as boot command

Expected results:
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_Basic_Video_Driver
Comment 1 Kamil Páral 2010-08-13 08:46:29 EDT
I believe this is a duplicated of bug #623129?
Comment 2 Clyde E. Kunkel 2010-08-13 10:41:06 EDT
nomodeset has to be passed in order to get a graphical installer with:

$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV630 [Radeon HD 2600 Series]
Comment 3 He Rui 2010-08-15 23:19:56 EDT
(In reply to comment #1)
> I believe this is a duplicated of bug #623129?

I tested F14-Alpha-RC4, it did use vesa driver during installation, but after reboot, when I checked the grub.conf, xdriver=vesa was not included.
Comment 4 He Rui 2010-08-15 23:20:38 EDT
Created attachment 438883 [details]
tmp logs during install
Comment 5 He Rui 2010-08-15 23:21:39 EDT
Created attachment 438884 [details]
logs after reboot to desktop
Comment 6 Adam Williamson 2010-08-16 11:25:10 EDT
what's written in the test at present - "The installed system is configured with a boot argument: xdriver=vesa. This can be confirmed by inspecting /etc/grub.conf or /proc/cmdline  on the installed system." - is not actually correct. This parameter is only considered by anaconda / live boot; it is *not* read by anything during boot of a normal installed system.

To make the installed system use the vesa driver, anaconda should in fact have written a /etc/X11/xorg.conf file which specifies 'vesa' as the driver. Please check that it did so. If it did, then all is fine. James will update the test case.
Comment 7 He Rui 2010-08-17 01:07:58 EDT
(In reply to comment #6)
> what's written in the test at present - "The installed system is configured
> with a boot argument: xdriver=vesa. This can be confirmed by inspecting
> /etc/grub.conf or /proc/cmdline  on the installed system." - is not actually
> correct. This parameter is only considered by anaconda / live boot; it is *not*
> read by anything during boot of a normal installed system.
> 
> To make the installed system use the vesa driver, anaconda should in fact have
> written a /etc/X11/xorg.conf file which specifies 'vesa' as the driver. Please
> check that it did so. If it did, then all is fine. James will update the test
> case.

Anaconda wrote this in /etc/X11/xorg.conf: 

Section "Device"
        Identifier "Videocard0"
        Driver "vesa"
EndSection

So that's why the installed system used vesa driver after reboot... Thanks Adam, then this is not a bug, and the expected result should remove the 'checking boot argument' and add this one instead?
Comment 8 Adam Williamson 2010-08-17 04:33:12 EDT
Yes. I've already updated the test case, in fact. thanks!

Note You need to log in before you can comment on or make changes to this bug.