Bug 623991 - Anaconda needs 1GB RAM for GUI installation
Anaconda needs 1GB RAM for GUI installation
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 07:24 EDT by Zdenek Sedlak
Modified: 2010-08-13 10:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 10:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Sedlak 2010-08-13 07:24:12 EDT
Description of problem:
Anaconda needs to have at least 1GB RAM for GUI installation, however RHEL6 can run on 512MB without any problems.

How reproducible:
Try to install RHEL6 beta 2 with less than 1GB RAM.

Steps to Reproduce:
1. Install memory (under 1GB RAM)
2. Boot RHEL6 b2 installation DVD
3. Select graphical installation
  
Actual results:
Anaconda shows a warning that there has to be at least 1GB RAM for GUI installation and continues with text installation.

Expected results:
Be able to run GUI installation with less than 1GB RAM (512MB is acceptable).

Additional info:
Comment 2 RHEL Product and Program Management 2010-08-13 07:57:54 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Zdenek Sedlak 2010-08-13 08:52:47 EDT
Ok, I've marked it for 6.1 instead. Is it OK or shall I create a support case?
Comment 4 Chris Lumens 2010-08-13 10:31:35 EDT
This is not a bug:

commit 02eefc89e7db5dbc3bc819ea854de45e0d1ebbc7
Author: Ales Kozumplik <akozumpl@redhat.com>
Date:   Wed May 5 11:00:59 2010 +0200

    memory: increase the RAM limits, check for URL installs (#549653).
    
    Due to higher memory consumption of LVM, kernel, anaconda and other
    running processes in general our current memory limits are insufficient
    and the increase is neccessary. I am also introducing additional check for
    URL installs which require another 108 MB from the ramdisk, no need to
    penalize other install methods.
    
    This is the current memory budget:
    - unpacked initrd takes 63 MB
    - running processes (anaconda, loader, udev, nm): 67 MB (estimate)
    - peak LVM memory consumption: up to additional 56 MB
    - with URL install install.img takes additional: 108 MB
    - memory requriements of X additional: 256 MB (estimate)
    
    Currently we always expect there will be calls to lvm (though we could do
    another memory check just at the moment where the necessity arises). All
    of the estimates are on the upper bound, still I am running into OOM
    easily with text install+http stage2+lvm detection with the old limits.

Note You need to log in before you can comment on or make changes to this bug.