Bug 624012 - SELinux is preventing /usr/bin/gnome-keyring-daemon "read" access on /home/dan/.gnome2/keyrings.
SELinux is preventing /usr/bin/gnome-keyring-daemon "read" access on /ho...
Status: CLOSED DUPLICATE of bug 538428
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:295a55e1652...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 08:33 EDT by Daniel Scott
Modified: 2014-09-27 17:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-16 09:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Scott 2010-08-13 08:33:02 EDT
Summary:

SELinux is preventing /usr/bin/gnome-keyring-daemon "read" access on
/home/dan/.gnome2/keyrings.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gnome-keyring-d. It is not expected that this
access is required by gnome-keyring-d and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:gnome_home_t:s0
Target Objects                /home/dan/.gnome2/keyrings [ dir ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-keyring-2.28.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64
                              #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 26 May 2010 01:19:10 PM EDT
Last Seen                     Wed 26 May 2010 01:19:10 PM EDT
Local ID                      681dde8b-8c2c-4392-9979-a80e5e3a76a8
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274894350.530:69): avc:  denied  { read } for  pid=4241 comm="gnome-keyring-d" name="keyrings" dev=dm-4 ino=12427274 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:gnome_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274894350.530:69): arch=c000003e syscall=2 success=yes exit=128 a0=1a542d0 a1=90800 a2=35f8b74e88 a3=8 items=0 ppid=1 pid=4241 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts3 ses=7 comm="gnome-keyring-d" exe="/usr/bin/gnome-keyring-daemon" subj=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gnome-keyring-d,passwd_t,gnome_home_t,dir,read
audit2allow suggests:

#============= passwd_t ==============
allow passwd_t gnome_home_t:dir read;
Comment 1 Miroslav Grepl 2010-08-16 09:48:26 EDT
This is an old F12 on an F13 box.

*** This bug has been marked as a duplicate of bug 538428 ***

Note You need to log in before you can comment on or make changes to this bug.