Bug 624032 - wireshark segfaults on several pcap files from regression test
wireshark segfaults on several pcap files from regression test
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: wireshark (Show other bugs)
6.0
All Linux
urgent Severity high
: rc
: ---
Assigned To: Jan Safranek
Karel Srot
: Regression
Depends On:
Blocks: 590615 604312
  Show dependency treegraph
 
Reported: 2010-08-13 09:24 EDT by Karel Srot
Modified: 2010-11-10 16:55 EST (History)
2 users (show)

See Also:
Fixed In Version: wireshark-1.2.10-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:55:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wireshark cap/pcap files from the regression test (746.31 KB, application/x-gzip)
2010-08-13 09:24 EDT, Karel Srot
no flags Details

  None (edit)
Description Karel Srot 2010-08-13 09:24:25 EDT
Created attachment 438682 [details]
wireshark cap/pcap files from the regression test

Description of problem:
During the regression testing of bugs 604312, 590615 I have found that wireshark/tshark segfaults on several pcap files from a regression test.
This is a regression, previous version wireshark-1.2.9-2.el6 does not segfault.

Unfortunately I am not able to identify what was the origin of those segfaults in the passed and provide related bug/patch. There may be only one unfixed error in wireshark but also there may be several independent errors.

Version-Release number of selected component (if applicable):
wireshark-1.2.10-1.el6

How reproducible:
always (tested on x86_64)

Steps to Reproduce:
1. download attached archive
2. tar -xzf tshark_crashers.tar.gz
3. for FILE in crashers/*cap; do tshark -nVr $FILE &> /dev/null || echo $FILE; done;
  
Actual results:
wireshark/tshark segfaults

Expected results:
no segfaults
Comment 4 Jan Safranek 2010-08-16 06:39:47 EDT
It seems to be already reported (and fixed) upstream:
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5072
Comment 5 Jan Safranek 2010-08-16 07:06:22 EDT
..and upstream fix (SVN rev. 33704) seem to fix the crashes.
Comment 11 releng-rhel@redhat.com 2010-11-10 16:55:02 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.