Bug 624035 - guestfish "upload /file foo" command hangs or gives a protocol error
guestfish "upload /file foo" command hangs or gives a protocol error
Status: CLOSED DUPLICATE of bug 576879
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 09:33 EDT by Richard W.M. Jones
Modified: 2011-04-12 13:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-12 13:35:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-08-13 09:33:01 EDT
Description of problem:

$ guestfish -i disk.img 

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for a list of commands
      'man' to read the manual
      'quit' to quit the shell

><fs> upload /bin/bash foo


Version-Release number of selected component (if applicable):

guestfish 1.5.2

How reproducible:

Always.  Matt reports that it doesn't hang, but gives a
protocol error instead.

Additional info:

Potentially this is a dupe of bug 576879.
Comment 1 Richard W.M. Jones 2011-04-12 13:35:30 EDT
Verified that this does not hang, crash, or lose
synchronization in libguestfs 1.9.18.

*** This bug has been marked as a duplicate of bug 576879 ***

Note You need to log in before you can comment on or make changes to this bug.