Bug 624085 - compat-db47 blocks online updates due to a conflicting file
compat-db47 blocks online updates due to a conflicting file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compat-db (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 11:35 EDT by Răzvan Sandu
Modified: 2013-07-02 19:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-29 12:45:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2010-08-13 11:35:55 EDT
Description of problem:

During regular updates in Fedora 13 (x86_64), package compat-db47 blocks the automatic updates via a conflicting file.

Here's what I get:

[root@imap1 ~]# yum -y --obsoletes upgrade
Loaded plugins: downloadonly, presto, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package compat-db47.x86_64 0:4.7.25-15.fc13 set to be updated
--> Processing Dependency: compat-db-headers = 4.7.25-15.fc13 for package: compat-db47-4.7.25-15.fc13.x86_64
--> Running transaction check
---> Package compat-db-headers.noarch 0:4.7.25-15.fc13 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch         Version               Repository     Size
================================================================================
Updating:
 compat-db47             x86_64       4.7.25-15.fc13        updates       1.2 M
Installing for dependencies:
 compat-db-headers       noarch       4.7.25-15.fc13        updates        58 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       1 Package(s)

Total download size: 1.2 M
Downloading Packages:
Setting up and reading Presto delta metadata
updates/prestodelta                                      |  52 kB     00:00     
Processing delta metadata
Package(s) data still to download: 1.2 M
(1/2): compat-db-headers-4.7.25-15.fc13.noarch.rpm       |  58 kB     00:00     
(2/2): compat-db47-4.7.25-15.fc13.x86_64.rpm             | 1.2 MB     00:01     
--------------------------------------------------------------------------------
Total                                           769 kB/s | 1.2 MB     00:01     
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  file /usr/include/db4.7.25/db.h from install of compat-db-headers-4.7.25-15.fc13.noarch conflicts with file from package compat-db47-4.7.25-2.fc13.i686

Error Summary
-------------



Version-Release number of selected component (if applicable):
compat-db47-4.7.25-2.fc13.x86_64
compat-db47-4.7.25-2.fc13.i686


How reproducible:
Always, on x86_64 platform.

Steps to Reproduce:
1. Try to update online an F13 x86_64 system with compat-db47 package installed.

  
Actual results:
Online update is blocked via conflict shown above.

Expected results:
Online update should perform normally.


Additional info:

Other reports on the matter do exist:

http://www.spinics.net/linux/fedora/fedora-users/msg375672.html
Comment 1 Bob Whitinger 2010-08-23 10:06:59 EDT
This bug blocks the yum upgrade from F12 to F13 on 64 bit systems, and it appears that there is no workaround for this bug.  The removal of the db4 packages is not a solution because rpm depends on it.

I would suggest that the priority on this bug be elevated if a workaround cannot be provided.
Comment 2 Tobias Florek 2010-08-25 10:12:26 EDT
and now it is all over again. update from f13 to f14 alpha yields conflicting file from compat-db-headers and compat-db47.

fortunately here it is easy to circumvent, because deinstalling compat-db-headers only deinstalls a handfull of dependencies, which i could reinstall after the update. maybe compat-db47 should (in a way, i do not know rpm that well) obsolete compat-db-headers. (or someone should tell me how a yum install compat-db47 compat-db-headers- works, i. e. a simultaneously removal of compat-db-headers and install of compat-db47).
Comment 3 Simon Schönbeck 2010-09-23 11:07:37 EDT
I encountered this issue too while upgrading a x86_64 Fedora 12 (was 8,9,10,11) to Fedora 13. This problem is caused by having packages from multiple architectures installed simultaneously.

Running the following fixed it for me:

yum clean all
yum -y remove db4.i686

This left my system with only the db4.x86_64 package.

Now updating with yum -y update was trouble free.

Note You need to log in before you can comment on or make changes to this bug.