Bug 624092 - Can't rhnpush to overwrite an existing rpm
Summary: Can't rhnpush to overwrite an existing rpm
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server   
(Show other bugs)
Version: 530
Hardware: All
OS: Linux
urgent
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Šimon Lukašík
URL:
Whiteboard:
Keywords: Regression, Reopened
: 654886 (view as bug list)
Depends On:
Blocks: sat54-errata
TreeView+ depends on / blocked
 
Reported: 2010-08-13 16:00 UTC by Justin Sherrill
Modified: 2018-11-14 16:36 UTC (History)
8 users (show)

Fixed In Version: spacewalk-backend-1.2.13-21
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 16:16:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0190 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2011-02-01 16:15:56 UTC

Description Justin Sherrill 2010-08-13 16:00:02 UTC
When rhnpush'ing a package that already existed, you used to be able to use --force to overwrite what was already there (in the channel).  Now you cannot.  When you try this, you get an error:


 Error Message:
    ORA-00001: unique constraint (RHNSAT.RHN_CNP_CID_NID_UQ) violated
ORA-06512: at "RHNSAT.RHN_CHANNEL", line 1091
ORA-06512: at line 1
Error Class Code: 23
Error Class Info: Could not update database entry.


and the 2nd package shows up under 'Manage software packages'.  essentially it's been pushed to the satellite (again), but couldn't be associated to the channel because the package already existed.

Comment 2 Justin Sherrill 2010-09-07 22:10:37 UTC
so i had forgotten about the enable_nvrea config option.  This only happens if enable_nvrea is enabled, which it is not by default in satellite (at least it shouldn't be).

SO this may not be such a high priority bug.

Comment 3 Clifford Perry 2010-09-07 22:20:10 UTC
Lol - oh yeah - Forgot we have a config option to disable --force. This is known. 

Notabug.

Comment 4 Justin Sherrill 2010-09-07 22:24:14 UTC
Still a bug, just not a satellite blocker :}

moving to -canfix

Comment 9 Miroslav Suchý 2010-12-15 16:12:00 UTC
*** Bug 654886 has been marked as a duplicate of this bug. ***

Comment 10 Miroslav Suchý 2010-12-15 16:19:08 UTC
Fixed in spacewalk.git commit d1a9e12d8b5409ab54c029a6a9b7e9f72d157a89

Comment 11 Miroslav Suchý 2010-12-16 17:18:32 UTC
cherrypicked as commit 77ce12aab7b3f9b45a1386d66b38f0e3a0000045

Comment 12 Miroslav Suchý 2010-12-16 17:26:01 UTC
err that cherrypick is commit 77ce12aab7b3f9b45a1386d66b38f0e3a0000045

Comment 13 Šimon Lukašík 2010-12-17 20:35:43 UTC
Changing to VERIFIED:

Testing procedure:
Automated test (v1.0-1)

Verified against:
spacewalk-backend-1.2.13-21.el5sat

Comment 14 Florian Nadge 2011-01-27 11:25:48 UTC
Please be so kind and add a few key words to the technical note of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks

Comment 15 Florian Nadge 2011-01-27 11:25:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:

Comment 16 Miroslav Suchý 2011-01-27 12:09:29 UTC
There is already nice text in errata.

Comment 17 errata-xmlrpc 2011-02-01 16:16:03 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0190.html


Note You need to log in before you can comment on or make changes to this bug.