Bug 6241 - Can't shutdown with nss_ldap installed - /usr is always in use
Summary: Can't shutdown with nss_ldap installed - /usr is always in use
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nss_ldap   
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-22 14:10 UTC by kevin_myer
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-22 15:29:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kevin_myer 1999-10-22 14:10:08 UTC
Hello,

I have been tracking development and using the pam_ldap and
nss_ldap modules from PADL software for about half a year.
I was pleased to see them included with RedHat 6.1.
However, after I began using the rpm versions, I found I can
no longer shutdown my machine, as /usr is always in use or
busy.  I think I have tracked down the problem to the
nss_ldap module.

Troubleshooting steps taken:

1) Attempt to shutdown the machine (shutdown -h or -r now)
2) machine goes to init 0 or 6 respectively
3) everything gets killed and umounted, except /usr because
its in use or busy
4) This requires a manual reset of the machine which of
course runs fsck on /usr everytime
5) Trying to figure out what was in use - init 1 to go to
single user
6) unmount all mounted file systems - /usr won't umount
because its in use
7) lsof to list open files - the only open files listed on
/usr (8,2) are of course lsof and friends AND the LDAP
libraries libldap and liblber
8) exit single user mode
9) rpm -e pam_ldap and nss_ldap
10) modify /etc/pam.d/login to not use LDAP
11) logout and log back in
12) shutdown -h or -r works now
13) reboot, reinstall nss_ldap, (but not pam_ldap) and
problem exists again

the ldap libraries are in use by sh and I did not have this
problem when using Red Hat 5.2 or 6.0 with nss_ldap that I
compiled myself.  That _may_ be because I never compiled
shared libraries of libldap and liblber and always included
the static libraries.

Comment 1 Bill Nottingham 1999-10-22 15:29:59 UTC
Should be fixed in nss_ldap-85-2, which will be in the next
Raw Hide release.


Note You need to log in before you can comment on or make changes to this bug.